Creating Rocky 8.7 KVM VM from local ISO installer fails


i have to create KVM virtual machines based on Rocky 8.7 (hypervisor is Rocky 9.1),
and fail to use the exact same workflow that flawlessly worked so far for Rocky9 VMs.

Problem 1): Creating a VM using cockpit in an interactive graphical installation using the VNC console wil always fail, because the rendering of the graphical installer cuts off the portion where the buttons would be rendered to step through the GUI.
This also holds when switching to using a standalone VNC client.
Also i tried 4 different browsers.
So it seems not to be a problem of rendering the GUI, but of creating it in a cut off manner.
This seems to be related to:
(machines: VNC Vertical Sizing is Off · Issue #8392 · cockpit-project/cockpit · GitHub)

Problem 2): Creating the same VM via virt-install and kickstart and using the installation ISO stored in the KVM filesystem always fails as soon as Anaconda is attempting to access the ISO image as a source for the packages to install.
Error message then:

"No mountable devices found"

This seems to be related to:

Problem 1 would only matter for me in order to determine the exact anaconda kickstart syntax for properly referencing the installation sources for a Rocky8 installation.
I.o.w.: actually i am looking for a solution for Problem 2:

I gues what would help me the most: how can i convince anaconda in kickstart config to use the ISO installer file from the local filesystem as a repo in a kickstart installation of Rocky 8.x?

Because it is so odd: all of that works when using the Rocky-9 installation ISO file for creating a Rocky 9 VM…

So I think you’ e saying installing a Rocky 8.7 vm guest works perfectly when using the Rocky 8.7 GUI installer, but fails when you try to switch to the text based installer with kickstart?

Thank you for chiming in!
Actually the situation is that both methods (text based kickstart, VNC-console based Cockpit) work flawlessly for Rocky > 9.0, but fails for 8.7, (and 8.3).

  • Textpased kickstart fails with anaconda not finding the installation sources.
  • Cockpit with that strange rendering problem, that cuts off the lower section of the screen, effectively the buttons. Which also applies for connecting to that installation with a VNC viewer, so i believe the bug is in the genration of the GUI, not in it’s rendering on client side.

I doublechecked with moving the ISO file into “/images”, but that did not help either.
If no one has an immediate solution handy, i would possibly switch to URL based installation source…

Just an update: it’s weird:

  1.” claims it would never be possible
  2.” claims it should be possible
  3. “https:XXbugzilla.redhat.comXshow_bug.cgi?id=1914955” tells it worked for somebody
  4. “https:XXaccess.redhat.comXdocumentationXen-usXred_hat_enterprise_linuxX7XhtmlX7.3_release_notesXknown_issues_installation_and_booting” claims another solution, but none of them worked for me.

It always ends up with the following:

Starting installer, one moment...
anaconda for Rocky Linux 8 started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2
 * if the graphical installation interface fails to start, try again with the
   inst.text bootoption to start text installation
 * when reporting a bug add logs from /tmp as separate text/plain attachments
13:48:41 Not asking for VNC because of an automated install
13:48:41 Not asking for VNC because text mode was explicitly asked for in kickstart
Starting automated install.Saving storage configuration...
.Checking storage configuration...


1) [x] Language settings                 2) [x] Time settings
       (English (United States))                (Europe/Berlin timezone)
3) [!] Installation source               4) [!] Software selection
       (Error setting up software               (Error checking software
       source)                                  selection)
5) [x] Installation Destination          6) [x] Kdump
       (Custom partitioning selected)           (Kdump is enabled)
7) [x] Network configuration             8) [ ] User creation
       (Wired (enp1s0) connected)               (No user will be created)

Please make a selection from the above ['b' to begin installation, 'q' to quit,
'r' to refresh]:
[anaconda]1:main* 2:shell  3:log  4:storage-log >Switch tab: Alt+Tab | Help: F1

Please make a selection from the above ['b' to begin installation, 'q' to quit,
'r' to refresh]: 3
Installation source

Choose an installation source type.
2) local ISO file
3) Network

Please make a selection from the above ['c' to continue, 'q' to quit, 'r' to
refresh]: 2
Select device containing the ISO file

No mountable devices found

Please make a selection from the above ['c' to continue, 'q' to quit, 'r' to
[anaconda]1:main* 2:shell  3:log  4:storage-log >Switch tab: Alt+Tab | Help: F1

refresh]: q

                          Do you really want to quit?

Please respond 'yes' or 'no': yes
[anaconda]1:main* 2:shell  3:log  4:storage-log >Switch tab: Alt+Tab | Help: F1

I also tried both the “Rocky-8.7-x86_64-minimal.iso” and “Rocky-8.7-x86_64-dvd1.iso”, but with no effect, it’s really an anaconda issue.

I don’t want to be stubborn, but installing from a local ISO would definitely speed up VM installations a lot.
And it’s still the most robust and simple approach…

Just in case someone comes here experiencing the same problem:

i also tried to provision the mounted ISO with a local web- and ftp-server,
but in both cases anaconda refused to use the files it actually found (e.g. install.img).
Instead dracut-initqueue falls back to looking for files on the server in a path “LiveOS”, which of course must fail.

At this point my impression is that maybe the installation ISOs are not compatible “somehow” with this kind of setup?
Switching to the stock online repositories for the installation sources immediatly works, and that’s what i am falling back to now.

Just as a reminder: i experienence all of this only for 8.x, while i have no issues with any of the tested methods for 9.x ISOs.