Kickstart fails on boot

Hello Team,
I am automating rocky linux installation.
Rocky9.1 image worked fine.
but rocky8.7 kickstart boot fails with the error
Started cancel waiting for multipath siblings of sda
ive tried this ks script for disk mangment and didnt work this is the exact script that i used for rocky9 that worked fine

ignoredisk --only-use=sda

Partition clearing information

clearpart --all --initlabel

Disk partitioning information

part /boot/efi --fstype=“efi” --ondisk=sda --size=600 --fsoptions=“umask=0077,shortname=winnt”
part / --fstype=“xfs” --ondisk=sda --size=5000 --grow
part /boot --fstype=“xfs” --ondisk=sda --size=1024

and tried this script that use zerombr insted and also same issue

Partition clearing information

clearpart --all --initlabel

Disk partitioning information

#autopart --type=lvm
part /boot --fstype=“xfs” --ondisk=vda --size=1024 --label=boot --asprimary
part pv.01 --fstype=“lvmpv” --ondisk=vda --size=15359
volgroup vg_os pv.01
logvol /tmp --fstype=“xfs” --size=1024 --label=“lv_tmp” --name=lv_tmp --vgname=vg_os
logvol / --fstype=“xfs” --size=14331 --label=“lv_root” --name=lv_root --vgname=vg_os

I’ve seen that message mentioned on forum, so you are not the first and issue might not be in kickstart.

What happens if you start interactive 8.7 installer on that machine?

normal instillation works,
i saw that the problem was present in all rhel 8.5 but it was fixed in rhel 8.7 but rocky 8.7 still not working

Also these are the changes that i made to isolinux.cfg and to the grup.cfg

label kickstart
menu label ^Kickstart
kernel vmlinuz
append initrd=initrd.img inst.stage2=hd:LABEL=Rocky-8-7-x86_64-dvd inst.ks=hd:LABEL=Rocky-8-7-x86_64-dvd:/anaconda-ks.cfg

menuentry ‘Kickstart’ --class fedora --class gnu-linux --class gnu --class os {
linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Rocky-8-7-x86_64-dvd inst.ks=hd:LABEL=Rocky-8-7-x86_64-dvd:/anaconda-ks.cfg quiet
initrdefi /images/pxeboot/initrd.img

after two days, the issue was the name of the iso image :smiley:

I have the same problem with an 8.6: A normal installation works but one with a kickstart file gives me the error: “started cancel waiting for multipath siblings of sda”.
Please, how did you solve it?

Hi dominTxomin,

I suspect this will be down the label or as mhk states the name of the ISO. I would take a look at the LABEL in isolinux.cfg and grup.cfg.

After that if you are still having issues, how are you generating the ISO?

Thanks Tom.

Hello, thanks for the answers.
I have tried with version 8.7 and the result is the same on a physical server(On a virtual server it works fine):
“started cancel waiting for multipath siblings of sda”.

I generate the iso like this:

mkisofs -o test.iso -b isolinux/isolinux.bin -J -R -l -v -T -c isolinux/ -no-emul-boot -boot-load-size 4 -boot-info-table -eltorito-alt-boot -e images/efiboot.img -no-emul-boot -graft-points -V 'Rocky-8-7-x86_64' .

The grub.cgf file:

menuentry 'ISO install' --class fedora --class gnu-linux --class gnu --class os {
        linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Rocky-8-7-x86_64 inst.ks=cdrom:/isolinux/my-ks.cfg
        initrdefi /images/pxeboot/initrd.img

I check the iso file:

isoinfo -d -i ./test.iso
CD-ROM is in ISO 9660 format
System id: LINUX
Volume id: Rocky-8-7-x86_64
Volume set id:
Publisher id:
Data preparer id:
Copyright File id:
Abstract File id:
Bibliographic File id:
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 1127041
El Torito VD version 1 found, boot catalog is in sector 210
Joliet with UCS level 3 found
Rock Ridge signatures version 1 found
Eltorito validation header:
    Hid 1
    Arch 0 (x86)
    ID ''
    Key 55 AA
    Eltorito defaultboot header:
        Bootid 88 (bootable)
        Boot media 0 (No Emulation Boot)
        Load segment 0
        Sys type 0
        Nsect 4
        Bootoff D3 211


In grub.cfg try replacing:



inst.ks=hd:LABEL=Rocky-8-7-x86_64 :/isolinux/my-ks.cfg

Thanks Tom.

Do u still have the problem ?

In the future, if you are trying to add a kickstart to an ISO, I woudl recommend using mkksiso. It will make things easier over trying to arbitrarily run mkisofs.

Thank you very much for everything. With the changes you mentioned it worked also on the physical server. I copied the ISO to a CDROM and it booted without any problem. Thank you.
Now I will make the changes to be able to use a usb stick instead of the cdrom but that’s another matter.

Good afternoon. I am trying to install from a usb stick:
In the kickstart file I have two sections %pre and two sections %post.
In the two %pre sections and in the first %post section, it correctly recognizes the usb stick:

/dev/sdb1 on /run/install/repo type vfat (ro,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)

The problem, and I don’t know why it happens, is that in the second section %post, it doesn’t recognise it and what’s more, it does something with it that makes it inaccessible, it doesn’t even recognise it on my laptop.
I have no idea what can happen
Any idea?

i understand that u have issue in the post section is unrecognized mean the instillation don’t do that the commands that u listed in the post section ??
can u share ur kick start file so we can help u
i think u need to specify the weather should ur code run in non chroot environment and what compiler u should use sh, shell, even u can use python3

Hello, I can’t test again until Monday.
I have made the following changes:
In the %post I have removed “interpreter” and in the next line I have put #!/bin/bash.
In the first %post, which works correctly, at the end what I do is to unmount the usb device.
In the second %post, I mount the usb device again.

On monday when I try it, I’ll let you know how it works and if so, I’ll put the kickstart file.


Good afternoon. I have finally been able to continue with the tests.
The break was a good thing because when I checked again the kickstart file I saw the possible failure of the usb device deletion. It was me who caused it. I thought I was only erasing the sda and I erased all the sd*. Tomorrow I hope to try again and I’ll let you know but it’s almost ready.

Good morning. Well, there is no way, I no longer delete the content of the usb device but I still cannot access it in the second %post.

First %post

%post --nochroot
echo “POST 1”
if [ ! -d /mnt/sysimage/root ]; then
mkdir /mnt/sysimage/root

→ output: /dev/sdb1 on /run/install/repo type vfat (ro,…)

lsblk -d -n -p -o NAME,TYPE | grep -E “/dev/sr|usb|/dev/sd|cdrom”
–>/dev/sda disk
–>/dev/sdb disk

blkid -s UUID
–>output: /dev/sdb1: UUID=“4E6C-CD85”

cp /tmp/type /mnt/sysimage/root/
echo “End POST 1”

Second %post:
%post --logfile=/root/test.log
echo date
unalias mv &>/dev/null
unalias cp &>/dev/null

ls -l /etc/sysconfig/network-scripts/ifcfg-*

echo “… mount (0) …”
–>output: NOT mounted (At another time I put it to mount and it told me it was busy)

echo “… df -h (0) …”
df -h
–>output: NOT shown

lsblk -d -n -p -o NAME,TYPE | grep -E “/dev/sr|usb|/dev/sd|cdrom”
–>/dev/sda disk
–>/dev/sdb disk <----

blkid -s UUID
→ output: /dev/sdb1: UUID=“4E6C-CD85” <----

What do I still need to do, do I need to do/activate something other than chroot like the first %post to make it work?
Thanks again


I am having this same issue with 8-8 and the multipath siblings. I have checked the label and I am still having the same issue. I am using geniso and it builds it fine or at least it is building it. However, I have two issues when I try and test it on virtualbox it gives an error if I do an unattended install and if I manually kick off the install I get the waiting for multipath siblings of sda.

Here is what my grub.cfg looks like:
set timeout=0
set default=0
menuentry “Kickstart” {
set gfxpayload=text
search --no-floppy --set=root -l ‘Rocky-8-8-x86_64-dvd’
linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Rocky-8-8-x86_64-dvd inst.headless inst.ks=hd:LABEL=Rocky-8-8-x86_64-dvd:/cdrom:/ks.cfg hpsa.hpsa_allow_any=1
initrdefi /images/pxeboot/initrd.img

Here is the isolinux.
default linux
label linux
kernel vmlinuz
append initrd=initrd.img inst.stage2=hd:LABEL=Rocky-8-8-x86_64-dvd inst.headless insta.ks=hd:LABEL=Rocky-8-8-x86_64-dvd:/ks=cdrom:/ks.cfg hpsa.hpsa_allow_any=1

Here is the errors that virtualbox throws.

VM Name: tes

VISO: Error setting name ‘/ks.cfg’ on ‘E:\VirtualBox VMs\tes\Unattended-11bc952d-a25b-4718-a06a-c725deb409a9-ks.cfg’: VERR_ALREADY_EXISTS (VERR_ALREADY_EXISTS).

VD: error VERR_ALREADY_EXISTS opening image file ‘E:\VirtualBox VMs\tes\Unattended-11bc952d-a25b-4718-a06a-c725deb409a9-aux-iso.viso’ (VERR_ALREADY_EXISTS).

Failed to open image ‘E:\VirtualBox VMs\tes\Unattended-11bc952d-a25b-4718-a06a-c725deb409a9-aux-iso.viso’ in read-only mode (VERR_ALREADY_EXISTS).

PIIX3 cannot attach drive to the Secondary Master (VERR_ALREADY_EXISTS).

Result Code: E_FAIL (0X80004005)
Component: ConsoleWrap
Interface: IConsole {6ac83d89-6ee7-4e33-8ae6-b257b2e81be8}

Any help would be appreciated

I am having the same issue with 8.8 and I copied your ks and grub and just changed the lable to 8-8 instead of 8-7 and it still is not working. Any ideas?

had the same issue with 8.8 and 8.9, The below fix from RHEL to ram image should fix the issue

Guide on how to extract and compress the ram image