Usb memory sticks and SD cards attached to a USB dongle all automount RO

Running Rocky 9.4 on x86_64.

Every time I plug in a USB stick, or attach a SD card via a USB-to-SD dongle, they always mount Read Only. I can’t find an incantation to use to let me write to the devices.

This has been ongoing ever since I installed RL 9, now over a year ago.

At one point I was able to unmount it then manually mount it (from a terminal window–accessing it from a GUI window seems to break the RW setting) with options to go RW, but today that either no longer works, or I’ve forgotten how I did it.

This is a real pain in the tush. Can anyone instruct me on how to get USB memory devices to mount RW?

Thanks in advance!


Hello Fred, I run a fully updated 9.4 laptop, but had never attempted to use a USB stick on it for read-write. I pulled a fresh USB flash drive out of the wrapper and plugged it in. I have RW abilities without doing anything. No granted, that’s a flash drive, but could it be something with the SD itself? I’m using a USB-C to USB-A adapter to gain access to the flash drive, but otherwise, it’s just a plug and play setup.


thanks for the reply!

I meant to convey that neither a USB stick NOR a SD in the adapter gives me write permissions.

Needless to say, it’s a pain in the rear.

I tried disabling selinux (temporarily) but it makes no difference. Not sure what else to look at.


What filesystem on the USB stick? Maybe change ownership of the files:

chown -R user:user /path/to/usb

replace user:user with your username, and change the path to the mounted usb stick accordingly. You’ll need to be root to do that, or use sudo with the above command.

@iwalker, already done that. :frowning:

most of the devices I use in that way are vfat, and as best I recall none of them mounts RW. I do have one ext4, which I just inserted and it DOES get mounted RW.

But I’m positive that vfat-formatted devices USED to work, but I am clueless as to what may have changed in that regard… or how to change it back.



one more piece of info:

I still have an old laptop with Centos-7 on it.

I just inserted one of the vfat usb sticks THAT DOES NOT WORK ON MY ROCKY DESKTOP, and it WORKS FINE on the C7 laptop.

booted the aforementioned ancient laptop into windows 7 (yeah, I know…), plugged in the drive and let it “fix errors” on the drive, which once moved back to Rocky mounts RW. don’t know if that is a permanent fix, 'cause in the past I’ve seen vfat devices go thru that process every time they are moved tom Linux to Windows and back.

Sorry for all the noise in the forum, I should have remembered to check that.


1 Like