Uninstalling a software from RL

Hi all,
I have a question around how to uninstall or completely remove the files associated with a software I accidently deleted while using sudo rm -rf *
I tried to reinstall this same software however the system thinks its already installed, i am unable to figure out how to complete “reset” this without having to reimage the entire RL OS.
Note, I installed this software via SSH by executing the .run file during the initial installation process, FYI.


It would help to tell us what package/software you installed. Otherwise we cannot tell you where to look.

Maybe the run file installed rpm packages, then you need to use dnf or rpm command to see if that package is installed and remove it. Or, perhaps the run file just extracted stuff, and you didn’t completely clean up what is on your system. In that case, use system tools like find to locate directories on your disk that might match the package name you installed.

But without more info from you, difficult for anyone to suggest anything more specific.

Also by reinstalled, do you mean dnf install or dnf reinstall? Because when you run reinstall, then it does not care if the package is already installed, it will just write the file again as if it’s an update or new installation.

1 Like

hi, thank you so much for responding to this.
I installed this .run file here
and the way im trying to install it is via ssh sudo ./EcoStruxureITGateway-

Have you tried running like this to see if additional parameters can be passed to it? For example:

sudo ./EcoStruxureITGateway- --help

to see if it has options to uninstall, etc.

unfortunately nothing comes up with that … :frowning:

I have a feeling since this is a run package, it installs other services which in not listed makes it harder to remove…

You would have to ask the people who provide EcoStruxureITGateway and ask them how to uninstall their package - especially considering it seems they offer no such functionality. The problem is caused by them.

If they don’t offer a parameter to pass to the script, or some kind of uninstall functionality, then that’s a bit of incompetence on their part. Perhaps their package when installed, does have an uninstall script in the directory where the package was installed. Unfortunately, you removed it by deleting that directory so can no longer reinstall their package due to remnants from it still existing on the disk somewhere.

Perhaps build a new Rocky install, then install their package on it. Try to find the uninstall script. Then copy the directory you manually deleted over to your problematic system and ensure it’s in the correct place where it was previously and then run that uninstall script. That’s pretty much the only way you are going to uninstall it. Either that, or just forget about it and live with the way your system is, or reinstall it again from zero.

i agree, thank you iwalker.
I will contact them directly hoping to some answers.

1 Like