TigerVNC Woes - What else is there?

I tried installing TigerVNC yesterday on to a server. I am setting it up for a customer to where I will have a secure VPN to it and I can remote into it and then get remote access into there servers behind a firewall for remote support.

It has been years since I have installed TigerVNC (probably since CenOS 6.5)

I just could not get it working. I followed several how to’s and tried everything for hours.

I could get it to work one time after reboot. It would give me logins for something about a repository, and I could cancel it. But then when I logged of the service went inactive until I restarted the box again.

I went ahead and setup xrdp, and that works really well.

Is xrdp secure? Is TigerVNC kind of dying off? Is anyone else using it? Is xrdp the latest thing?

What other remote access options do you use. I am administering Windows Boxes on the other end that have VNC installed on them. And I can get the VNC client to work fine, just not the server.

Try ThinLinc. It’s excellent and also has sound.

I think you must try TightVNC server instead TigerVNC server, more stable and more reliable or more better you can use xrdp server, I use xrdp server in my Rocky Linux, and I use remmina to remote. xrdp is already in repo official Rocky Linux.

I tried VNC once, but because of the 3D in Gnome/Cinammon a lot of the problems existed because VNC wouldn’t work with it - although this was years ago maybe the VNC options in Linux now work with 3D but I just haven’t checked/tested. At that point in time, I gave up, and either use NoMachine NX or xrdp.

I have tested TigherVNC on Rocky, it is composed of:

  • lightdm as displayer manger, (I didn’t make with gnome working)
  • icewm as windows manager
  • tighervnc is controlled by /etc/xinetd.d/xvncserver

Before I have tried with Gnome under centos7, but not working. Then with lightdm it is working , so I stay with lightdm for Rocky, it is working.