Thunderbolt - Forcing Scan & mounting of eGPU

I have a NVIDIA RTX 3090 housed in a Razor Core X eGPU housing. For sometime, I have been connecting this box via a Thunderbolt connection to a Dell 7760 & a Dell 7530 without much issue.
Recently, when I connect the Razor, more often than not, the Dells no longer see this Thunderbolt device. Eventually, the machines may see them and all is well.
I cannot see any reason why they machine will start seeing the connection, therefore I wonder if there is a way to force a scan and push the connection.
I know it is not a physical issue as when I connect the cable, the egpu fan starts and when I disconnect, it turns off.
Any thoughts are more welcome.

Dmesg shows the Razor box is connected …

[ 3437.724072] usb 3-12: USB disconnect, device number 14
[ 6866.029559] usb 3-8: new low-speed USB device number 15 using xhci_hcd
[ 6866.159240] usb 3-8: No LPM exit latency info found, disabling LPM.
[ 6866.164015] usb 3-8: New USB device found, idVendor=1532, idProduct=1209, bcdDevice= 4.51
[ 6866.164021] usb 3-8: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[ 6866.164025] usb 3-8: Product: Core X
[ 6866.164027] usb 3-8: Manufacturer: Razer
[ 6866.164030] usb 3-8: SerialNumber: B47DC104E9F09C877E40CE9BB9861B1F

[ 7317.680243] usb 3-12: new low-speed USB device number 17 using xhci_hcd
[ 7317.809430] usb 3-12: No LPM exit latency info found, disabling LPM.
[ 7317.813937] usb 3-12: New USB device found, idVendor=1532, idProduct=1209, bcdDevice= 4.51
[ 7317.813938] usb 3-12: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[ 7317.813939] usb 3-12: Product: Core X
[ 7317.813940] usb 3-12: Manufacturer: Razer
[ 7317.813941] usb 3-12: SerialNumber: B47DC104E9F09C877E40CE9BB9861B1F

I wondering if anyone had an idea for?

[   66.498774] ucsi_acpi USBC000:00: ucsi_handle_connector_change: GET_CONNECTOR_STATUS failed (-110)
[   67.978186] usb 3-8: USB disconnect, device number 4
[   72.488872] usb 3-12: new low-speed USB device number 6 using xhci_hcd
[   72.618373] usb 3-12: No LPM exit latency info found, disabling LPM.
[   72.623221] usb 3-12: New USB device found, idVendor=1532, idProduct=1209, bcdDevice= 4.51
[   72.623228] usb 3-12: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[   72.623231] usb 3-12: Product: Core X
[   72.623234] usb 3-12: Manufacturer: Razer
[   72.623236] usb 3-12: SerialNumber: B47DC104E9F09C877E40CE9BB9861B1F
[   87.702446] loop11: detected capacity change from 0 to 4096

I also have a thunderbolt hard drive that won’t mount on this machine but will mount on a very similar machine running Rocky 8. Is there a way to test if the Thunderbolt ports / drivers are working properly?

Are there hardware limitation for Rocky 8 deployment ? The issue above is on a Dell 7760 portable workstation. I have issues with thunderbolt and the wifi card. I did not have these issues with machine when it was running Windows. The machine has the Intel AX210 Wireless Card that only works with Kernel 5.10 so could there be a similar constraint for the thunderbolt hardware driver?

Per Intel’s support docs Intel - Linux Support for Intel Wireless Adapters, the minimum kernel version is 5.10 for the AX210… so using RHEL 8 / Rocky Linux 8, based on kernel 4.18, might not be the best choice for that particular hardware.

Granted, Red Hat adds newer drivers and modules to older kernel bases over the life of a major Red Hat release but, in your case, RHEL 9.2 / Rocky Linux 9.2 might be a better option for your system, as that’s based on kernel 5.14 …

There’s nothing inherently wrong with your Precision–indeed, I’m typing this on a 7550 using a WD19DCS and three WQHD external displays–it’s just probably going to work better on a later version of the linux kernel.

I found that Thunderbolt 3 took several years after its initial release to become mostly-stable across a number of different laptop vendors for use with linux; I imagine there could be a similar–but hopefully far shorter–period of time before TB4 functionality in linux matches that when running Windows.

Again, if you’re not specifically required to run RL8 per IT/Mgt or due to some specific application compatibility, I strongly recommend checking into RL9 and its newer base kernel.

Good luck!

My apologies, also meant to reply to this part specifically.
You can try forcing a PCI bus rescan by running this as root:

# echo 1 > /sys/bus/pci/rescan 

Hope this helps!

Thank you LinuxGuy1997 for your thoughts. I wanted to install Rocky 9 but the apps that I use are all based on Rocky 8 and seemingly don’t work very well on 9 yet.
I blindly assumed that Rocky worked on all machines … but now I realize that I haven’'t bought a new machine in a very long time, so I had better be more vigilant on the hardware I acquire in the future.

This didn’t used to be a problem, years back Linux practically supported everything. There mostly were always problems with new hardware, or something exotic that may not work in the beginning but would appear sometime in the near future. But yes, RH took to limiting older hardware support with EL9 to x86_64-v2 so then older hardware started to be unsupported.

I suppose in the long run, attempting to support all old hardware becomes problematic and time-consuming hence the reason for limiting it to make things easier to concentrate on a smaller hardware set. Obviously for users this can be an issue meaning time to upgrade older machines and replace them at an extra cost to us. Either that, or utilise a different distro in the meantime, Debian for example which even still provides 32 bit versions. So I could still even run it on my old AMD Athlon from 20 years ago :slight_smile:

I’ve tried the command below but it does not show anything.

# echo 1 > /sys/bus/pci/rescan 

I read this page
which was interesting but did not produce any real results. I can see the box in the dmesg so I presume that it is good for the BIOS.
Very occasionally, the Rocky thunderbolt settings interface recognizes the box and mounts it. But I have not been able to work out how to repeat this special moment. So I know it can work. I don’t know how to force to mount, apart from plugging and unplugging and that invariably does not work.

Can anyone tell what the authorization process is?

The Arch Linux Wiki has some great information on devices, functions, and subsystems, even if you’re not running Arch itself. Section 2 on their Thunderbolt page answers your question without having to go through all the heavy Intel Thunderbolt technical documents and specifications. :grinning:

While you’ve likely already addressed this, it’s always worth mentioning–especially when it comes to TB3/TB4 docks and peripherals: absolutely verify you have the latest BIOS and TB firmware for your computer, as well as the latest firmware for each and all TB3/TB4 devices connected to it. It really can make quite a difference in functionality and/or stability!

Thank you so much for the Arch article. It explains what I need to know.

You’re most welcome. Hope you’re able to get things running smoothly soon!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.