Intel 225 problems in Rocky 9.2 - ASUS B550


Have recently upgraded my motherboard from an ASUS 450 to an ASUS 550.

Took the cards i had in the old box - Intel Dual Port PCIe Gigabit ethernet and Intel Dual Port 10GBe and moved them to the new board.

These cards had both been working for the last 2 years under firstly Centos 8, then for the last 3 months under Rocky 9.2

When i boot now - the 1GB card is not recognized - no listing in lspci and nothing in dmesg.

I thought i would therefore try the onboard 2.5GB port(s) which are Intel 225 Rev 3 - but see the problems that are listed all over the internet with frequent random dropouts etc

It appears that when the igc driver is loading for the 225 ports it is conflicting as i can not activate the other Intel cards. The 10GB is recognised but i can not get it to load its VLAN config and attach to my switch at all.

I would like to stop the 225 drivers loading and do some experimentation with the 1GB dual port and the 10GB card

Can anyone advise is there a way to do this in Rocky ?


Reseat the card?
Are some PCIe-slots and M.2 connectors mutually exclusive on that board? If there is NVMe “stealing” shared lanes …

You probably can disable the NIC in BIOS. No device listed → nothing to load drivers for.

I have tried a different slot and a different card just in case that was the issue (sorry should have mentioned that in the original Post)

I did not even think about the BIOS option - will try that tomorrow and report back

Yes i believe the NVME share lanes but i do not think they take them over completely - not using them so will look to see if i can disable them also


Yep did some looking last night - the online manual says that various modes of M.2 slots and population of different x16 slots share the bandwidth with the Thunderbolt and PCIex1 slots.

What they really mean is that they disable certain slots and features !!

So i will wait for this big copy i am doing to finish and will then shutdown the machine and delve into the BIOS - will report back once done


OK guys this now gets weirder.

I managed to disable the I225 ethernet ports in the BIOS and then installed a brand new Intel Dual port card in one of the PCieX1 slots and the board is recognized.

However i now see some more behaviour that i now realise was hanging around previously.

What i am seeing is documented in this post

Essentially i am trying to setup a bond for the two x 1GB ports to a Brocade 6610 switch (i have also tried it with 2 x 10GB ports) and can not get the bond to come up and forward packets - the switch
thinks the ports are OK but i can not get anyting through them.

Essentially it appears that the Bond does some weird stuff with Mac addresses when trying to bring the links up.

I am going to try the workaround listed in the above post and see if that gets me any further.

Will report back


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.