Linux Virtual Console (ctrl + alt +FN ) only displays login prompt on integrated graphics (intel) but not nvidia GPU

Hello Everyone,

I’m new to Rocky (fairly new to Linux in general). I’ve been an end user on Centos 7 but now dabbling into sys admin in our academic computing labs. I have Dell Precision 3650 with integrated intel graphics and Nvidia GPU RTX 3070. The issue is:

When i invoke ctrl+alt+FN (2-7) , I see just a text output:

[ 0.665959] integrity: Problem loading X.509 certificate -126

but no login prompt when the video cable is plugged into the Nvidia GPU. However, if I plug it into the intel integrated graphics port, I get the login prompt.

I am not sure where to look in terms of troubleshooting. I did google on the nvidia forums and many have suggested using nomodeset in the /etc/default/grub but the problems people had was a blank screen. I’m not getting a blank screen, just not the login prompt.

We don’t have any use for the integrated graphics so I was hoping to divert all display functions to the nvidia GPU. I’ve installed the nvidia driver and it’s working.
We run gnome as the desktop so that shows up without issues. There doesn’t seem to be option to disable the integrated graphics only to pick which is primary which I have but that does not seem to work.

Thank you for your time and assistance,

Below are some settings and confirmation of nvidia drivers working.

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation RocketLake-S GT1 [UHD Graphics 750] (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GA104 [GeForce RTX 3070] (rev a1)

nvidia-smi
Tue Dec 12 10:59:52 2023
±--------------------------------------------------------------------------------------+
| NVIDIA-SMI 545.23.08 Driver Version: 545.23.08 CUDA Version: 12.3 |
|-----------------------------------------±---------------------±---------------------+
| GPU Name Persistence-M | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap | Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|=========================================+======================+======================|
| 0 NVIDIA GeForce RTX 3070 Off | 00000000:01:00.0 On | N/A |
| 0% 34C P8 7W / 220W | 52MiB / 8192MiB | 0% Default |
| | | N/A |
±----------------------------------------±---------------------±---------------------+

±--------------------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=======================================================================================|
| 0 N/A N/A 1643 G /usr/libexec/Xorg 36MiB |
| 0 N/A N/A 1677 G /usr/bin/gnome-shell 8MiB |
±--------------------------------------------------------------------------------------+

We are running rocky 9.3
specifically:

uname -r
5.14.0-362.8.1.el9_3.x86_64

I would suggest disabling the integrated graphics in your BIOS.

Hello Stevemowbray,

Unfortunately the Dell precision 3650 does not have a disable integrated graphics option in the BIOS.

https://www.dell.com/support/manuals/en-us/precision-3650-workstation/prec_3650t_sm/system-setup-options?guid=guid-c2b72365-449b-4235-8e65-5df4d3d0f913&lang=en-us

by default it’s set to “Auto” and the other options are selecting which is the primary, intel or nvidia and selecting Nvidia does not change the behavior.

Thank you for your time.

Infuriating, isn’t it? I have couple machines with same issue, but I never tried to connect a display to the IGP. I just cope without virtual console. (Well, I do ssh in from other machine most of the time anyway.)


Isn’t it “framebuffer” (or something) that draws the virtual consoles?
Does it have configuration somewhere? Something to say: “draw with 01:00.0”.

jlehtone,

Absolutely infuriating! It seems this possible in earlier generations now we’re just stuck.

where might I find “draw with 01:00.0” setting?

Thank you for your time

I have a version of this problem

F1 the boot process what is loaded
F2 what should be the log on screen
F3-6 different sessions of terminal

Just cause I have this issue, I’m not sure it applies to you…

Fancy logi keyboard, the function keys have duel uses.

‘why does nothing work’ arr the function keys are in media mode.

And some of these screens here took a few seconds to go from a - in the corner to the full behaviours.

As for the actual issue it might be this

which I don’t have access to read.

Yani

Finally figured out a fix and I stumbled across this randomly. I had an issue with nvidia drivers from repo breaking after Kernel update 5.14.0-362.18.1.el9_3.0.1.x86_64 and we decided to use RPMfusion to manage our Nvidia drivers. After installing RPMfusion nvidia drivers, ctrl+alt+FN no longer worked. before I would at least see the screen wit the Problem loading X.509 certificate -126. Now it doesn’t even trigger the screen change. Googling rpmfusion and virtual console broken, I found a conversation on reddit

https://www.reddit.com/r/Fedora/comments/8gf8mu/rpm_fusion_nvidia_drivers_on_fedora_28_appear_to/

  1. uncomment WaylandEnable=false in /etc/gdm/custom.conf
  2. reboot

A voila, virtual console is working.

I have not gone back to testing this on nvidia repo driver if that is the fix as well but I’m so happy VC is working.