System reboot during install of Rocky 8

Hi. I need to install Rocky linux 8 in my new server but the system always reboot after I press “Install” in the grub. The server is completely new core i9 13th 64 ram. I try with Windows and it was installed successfully without problem. Could you help me please i need rocky 8. Thanks and sorry for my english.

Sounds like something is crashing or maybe even causing an NMI, resulting in the unexpected reboot.

You did not mention which version of Rocky Linux 8 you’re attempting to install… an i9 13th-gen is fairly new, so I’d recommend using the latest Rocky Linux 8.8 installation media; that way you will have the latest kernel and Intel microcode etc.

Also verify your computer has the latest BIOS installed–this can be especially important on newer machines with recently-released processors and chipsets.

Not sure what video card is in use on the system, but you can try ruling out potential driver issues by attempting to launch the install in text mode instead of the usual graphics one:

  1. Boot the installer as you’ve already done.
  2. Ensure the line “Install Rocky Linux 8.x” is highlighted first (use arrow key up/down if not), then press the tab key.
  3. A line starting with “vmlinux initrd=initrd.img” should appear at the bottom of the screen; hit space and then type the following:
  1. Press enter to boot the installer using text mode only.
  2. If you’re able to reach the main text install menu then it might be related to a graphics driver issue.
  3. If the computer still unexpectedly reboots before reaching the text-based installer then you might need to dig a bit deeper…

Hope this helps!

Hi, thanks for you answer. I updated the bios to its latest version. I also tried inst.text but it did not work. The Rocky linux version Im using is 8.8. I also tried with version 9.2 or other linux dist but the same problem remains. Do you have any other idea? the motherboard is B760M DS3H DDR4 (rev. 1.0)

OK, you’ve tried both the 8.8 and 9.2 Rocky Linux installers – the latest available for each major version. Good…

BIOS is updated, good…

What do you mean, exactly, by the text mode option not working? It goes to a black screen and never responds, or it reboots after hitting enter to install it in text mode, just like when trying the default graphical one?

Hey, wow, that looks like a pretty sweet board from Gigabyte! :grinning:

So I guess you’re on BIOS F12 for it now…

A quick search on the web seems to indicate many people experience issues when attempting to install linux on motherboards using the Intel B760 chipset, so you’re not alone…

The fact that you were able to install Windows 11 without issue makes me doubt it’s an issue with bad or defective hardware.

Not having one of these particular motherboards to test, I wonder if there might be an issue with the UEFI mode – if there is a “UEFI with compatibility mode” sort of option in the motherboard BIOS you could try that to see if it makes any difference.

Not knowing what video card you’re using, again, that could be related as well. Is it an AMD or NVIDIA one? If so, which model?

I know you said you’ve tried some other linux distributions with no luck, but one I would recommend trying is Arch Linux. You don’t even need to install it, just simply try to boot its installer on a spare USB stick and see whether or not you reach the command prompt as part of the install.
(you can simply reboot or power off the machine from there, no need to install it, as it’s not the best choice for people only getting started with linux – don’t want to add any extra stress to what you already have!)

The only reason I am suggesting this is that it tends to have much newer kernel releases than most distributions, so you could potentially see if the problem is related to lack of hardware support in older kernel releases. If it boots up OK then that might be the issue…

Good luck!

Hi. when i add inst.text it initialize the install and then restart again, there was not any change. Now i tried to install a proxmox and i have this error. Is there any relevant info here? Also, i do not have any special video card. This pc is going to be used as server for programming.


That definitely indicates that the display server,, is unable to figure out a proper display driver for your system. Likely the same problem you’ve seen with Rocky, although Rocky does that whole unexpected reboot thing…

Proxmox is a great Debian-based KVM distro, and I know for a fact that it has a non-graphical (text) mode installation. For instance, on the Proxmox VE 8.0 installer, the second option down at the boot screen should be “Install Proxmox VE (Console)” – use the down-arrow key, ensure it’s highlighted, then just hit enter to try it without the graphical console bit.

Luckily, if you’re mainly using this as a server, text console is fine for day-to-day use–especially with something like Proxmox, which has an excellent WebGUI you can access from another machine on the network.

If even the Proxmox text mode install fails to start then I’m stumped.

So are you using an actual video card at all, or just the integrated GPU built into some of the i9 13th gen CPUs? Looks like the i9-13900K, i9-13900T, i9-13900, and i9-13900KS all have Intel UHD Graphics 770 integrated GPUs (the i9-13900KF and i9-13900F have none).

I’ve not seen any reports of issues booting linux using the Intel UHD GPUs recently, though, so that would be odd…

I use the integrated GPU of i9-13900KS. It do not have any special nvidia o amd video card. I finally installed proxmox 8, but … now when i press “proxmox” in the grub it restart again. so, wow … maybe i have to update the drivers with windows where i do not have any conflict.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.