[Rocky Linux 9]: Zen 3 Kernel Panic


I am testing Rocky 8 and 9 on bare metal:

CPU: Ryzen 5800x
MB: Asrock B550m Steel Legend (2.62 Bios)

Rocky 8.8 works without issues.
But the 9.2 installation media gave me a kernel panic during installation.

  • I’ve tried searching for a solution on various sites, but most of them are pertained to virtual machines.
  • Zen 3 5800x also supports x86-64-v3. So I don’t think Zen 3 is too old for 5.14 kernel and RHEL 9.

Your insight is much appreciated.


I suppose you used an iso image. Can you check the hash value and confirm it is not broken?


Thanks for your suggestion.

I checked the hash as following:

certutil.exe -hashfile .\Rocky-9.2-x86_64-minimal.iso SHA256
CertUtil: -hashfile command completed successfully.

From Rocky’s official checksum


So I think the minimal iso file in used is not corrupted.
I created the bootable USB with rufus.

How did you use rufus? Did you use dd mode? I would try to use dd mode only or choose another image writer. Beyond that, ensure your system’s firmware is fully up to date.


Recreating the bootable usb with dd mode solved the issue for me.
I am not awared that using iso mode could cause such issue.

Rocky is up and running.

Thanks for your help.