Successful and not-so-successful RL 9 install attempts

My first attempt to install was going to be on a 2011 Mac mini previously running RL 8.6, but I accidentally pulled a 2010 model mini server from my box o’ spare minis. They look exactly alike aside from the 2010 box having a miniDP logo and the 2011 having a Thunderbolt logo on the back. Being a Core 2 Duo system, the 2010 gave a kernel panic on boot. I then tried the install on a Dell Precision 6600 laptop which has an Ivy Bridge i7 if I’m not mistaken. It went through the install process and then rebooted and told me that no boot device could be found. So I’m starting to bum a little bit. Then I noticed that I had tried installing on the wrong mini and tried the 2011, which is a Sandy Bridge i5 based system. Install went trouble free off the minimal install DVD, then a Server with GUI install got Gnome running. Red Hat must be aware that people are using Apple hardware since when I did Settings/About it tells me Hardware Model: Apple Inc. Macmini 5,2 which is Apple’s model designation for a 2011 mini with 2.5 GHz i5. Kind of slick I would say. Odds are that Apple didn’t expect this box to run software with support until 2032, which is also kind of slick. So next on the agenda is to figure out why the Dell laptop failed to boot after installation.

1 Like

had a similar problem myself installing rocky for the first time, turned off secure boot and I was able to see the efi system on boot, but from my experience from working with the old Dell precisions they sometimes still want to be booted into legacy mode or will swap the default boot device randomly in the bios.

This may not be ideal but it’s worth checking to further troubleshoot.

Curious since it’s set for EFI boot and had a Win Server 2012 R2 install running on it before I pulled the boot disk and swapped in another one for the RL install. A bit more fiddling is in order if I’m inclined to run RL on it I suppose.

you may only need to switch secure boot off, boot into RL then turn secure boot back on. I’m not sure exactly how secure boot works but the idea is to prevent non-authorized boot devices. Could be using a white list of some description? ahhh I’m already curious let me see what I dig up on secure boot…

Ha seems the answer may of been on this forum discovered through trial and error
How to enable secure boot on Rocky 8.5 - General - Rocky Linux Forum

It seems that secure boot has a set of keys it registers based on the current boot setup and there is someway to reset these keys but I don’t recall anything that simple in the Dell bios menus back in the day.

I hope this gives you more insight into the situation.

Yes, motherboard can store “keys” on flash (just like it has “BIOS settings” and “EFI Boot menu”).

The key that they all(?) have is from Microsoft. One can load additional keys with mokutil. (For example, ELRepo has their own key.)

On boot with Secure Boot on the EFI checks that the binary to be loaded (bootloader, kernel) is signed with (CA? of) one of the keys that the beard has. If not, the load is aborted. Similarly, kernel checks each kernel module; modules that do not pass (are not signed or were signed with unknown key) will not load.

The options on “bios menus” for managing keys do indeed tend to be limited.

1 Like

I was thinking this antique Dell would be too old for any secure boot worries, but I’ll have to give it a look.