9.3 installed on MacBook Early 2011...ethernet / wifi issues

Yesterday I successfully installed 9.3 of my old Early 2011 MacBook Pro.

I followed the directions on Linux sur un MacBook Pro 13″ de 2009 – Le blog technique de Microlinux and after getting the disk set up right everything went well. I didn’t expect the wireless to work right out of the gate and it didn’t. Fortunately Macs back then had a real ethernet port and that came right up. I did the dnf group install of Server with Gui and that worked fine.

I now have 3 kernels to choose from on boot:
vmlinuz-5.14.0-362.13.1.el9_3.x86_64
vmlinuz-5.14.0-362.8.1.el9_3.x86_64
vmlinuz-0-rescue-ed37ab317b9b45c9a6a7f3e3a60f7791

The vmlinuz-5.14.0-362.13.1.el9_3.x86_64 boots with no sign of the ethernet. The vmlinuz-5.14.0-362.8.1.el9_3.x86_64 and the rescue kernel both boot with working ethernet.

None of the three will bring up wifi for any devices I’ve tried, including the built in Broadcomm. I’ve got 2 usb wifi’s (one shows up as rt2800usb and the other as mt7601u) that look like they are loading and should work but neither makes any attempt to connect to our access point or shows anything with “nmcli device wifi list”.

Any clues as to why that .13 kernel doesn’t bring up the ethernet or how I can fix that? Can I just delete that .13 kernel so the .8 is the one that boots automatically? And if anyone has any advice on how to get the wifi (any wifi!) working would be greatly appreciated.

Thanks!
Jeff Ross

Did a dnf update and got a new .13 kernel that boots up with ethernet so that part is fixed already.

No change in the lack of wifi though.

Jeff

You may find the wireless driver you need from elrepo. Or perhaps their kernel-lt or kernel-ml might have the wireless driver. You could probably try those.

Since you have a Broadcom wifi card, you can try the following to install some Broadcom drivers:

Install RPM Fusion non-free (I dont think you need the free) - you can do this by going to the site and following the links.
https://rpmfusion.org/

run
sudo dnf install akmod-wl

Reboot

Hope that helps.

Update…

So far neither the elrepo kernels or the akmod-wl drivers have worked with any of the 3 wifi adapters I have available.

elrepo does find and load firmware for two of the three wifi adapters but none of them are getting an IP address from our open wifi network.

I found a great source for using broadcom adapters on Ubuntu:

If the broadcom devices all require firmware can I just download the firmware files for ubuntu and install them on my rocky linux MacBook?

It’s hard to imagine that of all the wifi adapters I’ve tried–including the ones the elrepo kernels found and then installed firmware for–fail to even attempt to get an IP address. It seems like I’m missing a bigger problem here but at this point I have no idea what that might be.

Jeff

I’ve got wifi working using one of the USB wifi adapters. It shows up as an mt7601u.

As it turned out, all I had to do was

nmcli radio wifi on

to enable wifi and it picked up the access point and got an IP address.

And better yet it is comes up with the latest Rocky 9.3 kernel so no messing around with elrepo.

Thanks for the replies nazunalika and RL1000!

i also have issue with wifi and broadcom on alma linux 9.3