Rocky Linux 8.7 on old iMac : trouble with kmod-forcedeth


I’m currently trying to make Rocky Linux 8.7 behave on a 2009 iMac. The NIC is an infamous NVidia MCP79 which is supposed to work with the kmod-forcedeth driver.

I copied over the kmod-forcedeth RPM from a USB key, installed it and rebooted, but I only got a freeze relatively late in the boot process.

Any suggestions on where to go from here ?

After installing 8.7, did you run ‘dnf update’ before installing kmod-forcedeth? I wonder about the version of the running kernel and that of the kmod. The current version of kmod-forcedeth does not work on the 8.7 GA kernel (I need to confirm this).

If you cannot boot the system at all, maybe it’s easier to do a reinstall of Rocky 8.7 and try again.

1 Like

OK, I suggest the following steps:

  • Install Rocky 8.7 (but don’t update the system)
  • Install kmod-forcedeth-0.0-8.el8_7.elrepo.x86_64.rpm so that you can use network
  • Update the system to the latest kernel 4.18.0-425.10.1.el8_7 AND kmod-forcedeth-0.0-9.el8_7.elrepo (need to do both)
1 Like

Thanks very much for your precious help. I had a partial success, but your suggestions helped me figure it out. And on a side note, I remember you from the CentOS mailing list back in the days, where you’ve helped me on numerous occasions. Much appreciated.

Right, here goes.

So right after installing, I downloaded and installed kmod-forcedeth-0.0-8. After rebooting, no freeze on startup and the NIC worked perfectly.

Then I proceeded to update the system, but after a reboot, I got a hard freeze on startup.

Started up again, and BTW : no, I did not reinstall everything. Just issued modprobe.blacklist=forcedeth on the GRUB prompt and removed the faulty driver.

Then I manually reinstalled the previous version of kmod-forcedeth, and it worked again with the updated kernel.

So for now I’ve added this to /etc/yum.conf:


Maybe we should give a heads up to the good folks at ELRepo to relegate the kmod-forcedeth-0.0-9 package to testing for the time being ?