Kmod-isci-1-2-0-4 with latest kernel update problem

I have intel controller for my disks. It worked perfectly in Rocky Linux 9.3 kmod-isci-1.2-0-4. After latest kernel update it does not work anymore. I unistalled rpm and the installed rpm again. No luck. Disks attached to intel controller do not appear anymore. Is it possible to inscpect this problem?

Just to confirm your note: kmod-isci-1.2-0-4 worked with kernel-5.14.0-362.8.1.el9_3 but stopped working with kernel-5.14.0-362.13.1.el9_3.

Is this correct?

I confirm that the latest kernel update broke a number of kmod packages. We will rebuild them and let you know when the updated kmod-isci is available.


The following package has been built and released:


It was built against kernel-5.14.0-362.13.1.el9_3.x86_64. It will show up on our mirror sites shortly.

Toracat. It works perfectly. Just a quetion? Could you include kmod-isci module in future Rocky kernels? Thank you for your quick replay.

Rocky linux is aiming to be binary compatible with RHEL. Therefore, its kernel cannot be modified. I suggest you keep the elrepo respository enabled. In most cases within a major release (for example, Rocky 9.2, Rocky 9.3, etc), you don’t need to update the kmod package with a new kernel. However like in this particular case, the kABI breakage occurred within 9.3. ELRepo will try to catch this type of situation and publish an updated version of kmod.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.