Rocky Linux 8.4 to Rocky Linux 8.5 update issues

Hi,
We have rocky Server 8.4 running on x86 and aarch64 architecture.
While trying to update to x86 server to Rocky 8.5

Whereas on aarch it is not detecting any updates for 8.5

Did any one able to update RL 8.4 to RL 8.5 ?

Use options “–allowerasing” and “–nobest” on your dnf command, you should upgrade your system.

i.e. dnf update --allowerasing --nobest

It works for me.

1 Like

Ugh! Thank you for the workaround. I just arrived to work and my email is full of failed update reports from our RL 8.4 servers.

Edit: Even after updating and restarting the server, the above error still shows up. But the security updates have been installed which was more important. I’ll wait for the RL team to fix the other problem.

I have the same problem, but I think someone isn’t building the dependencies properly.

 Problem 1: package libstdc++-devel-8.5.0-3.el8.x86_64 requires libstdc++(x86-64) = 8.5.0-3.el8, but none of the providers can be installed
  - cannot install both libstdc++-8.5.0-4.el8_5.x86_64 and libstdc++-8.5.0-3.el8.x86_64
  - cannot install the best update candidate for package libstdc++-devel-8.4.1-1.el8.x86_64
  - cannot install the best update candidate for package libstdc++-8.4.1-1.el8.x86_64
 Problem 2: libgomp-8.5.0-3.el8.i686 has inferior architecture
  - package gcc-8.5.0-3.el8.x86_64 requires libgomp = 8.5.0-3.el8, but none of the providers can be installed
  - cannot install both libgomp-8.5.0-4.el8_5.x86_64 and libgomp-8.5.0-3.el8.x86_64
  - cannot install the best update candidate for package libgomp-8.4.1-1.el8.x86_64
  - cannot install the best update candidate for package gcc-8.4.1-1.el8.x86_64

Note that the previous package is libgomp-8.5.0-3.el8.x86_64 and the new one libgomp-8.5.0-4.el8_5.x86_64 - the difference instead of being el8, it has been done as el8_5. The same with the libstdc package as well. The naming convention should have been the same so el8 and not el8_5, so there are a mix of packages not being built to the dependencies properly. So one package is relying on the old package, and others on the new package, but because both cannot be installed at the same time, a conflict occurs.

This occurred for me once when I started using Rocky and needed to install a pip for python I couldn’t do it because of this.

Exact same issue here, dependency mixup that needs to be fixed.

Same here. Will this be fixed by the developers? (thanks)

Confirm same issue. Hope for a fix! (thanks in advance)

We’ve observed that mirrors.rockylinux.org currently serves mirrorlists for “AppStream” where each URL points to the “kickstart” tree instead of the “os” tree. For example:

$ curl 'https://mirrors.rockylinux.org/mirrorlist?arch=x86_64&repo=AppStream-8' 2>/dev/null | head -n 5
# repo = rocky-AppStream-8.5 arch = x86_64 country = global 
http://la.mirrors.clouvider.net/rocky/8.5/AppStream/x86_64/kickstart/
http://dl.rockylinux.org/pub/rocky/8.5/AppStream/x86_64/kickstart/
http://mirror.i3d.net/pub/rockylinux//8.5/AppStream/x86_64/kickstart/
https://mirror.yandex.ru/rockylinux/8.5/AppStream/x86_64/kickstart/

The problem w.r.t. the missing libstdc++-devel-8.5.0-4.el8_5 update package most likely stems from this (since the update is present in the “os” tree, but not in the “kickstart” tree).

Edit /etc/yum.repos.d/Rocky-AppStream.repo like this:

#mirrorlist=https://mirrors.rockylinux.org/mirrorlist?arch=$basearch&repo=AppStream-$releasever
baseurl=http://dl.rockylinux.org/$contentdir/$releasever/AppStream/$basearch/os/

works here!

1 Like

Yes, this will work temporarily for now. Our mirror manager decided it wanted to choose kickstart over os for where it is pulling packages. This should be fixed soon.

2 Likes

removed gcc , update work , then reinstalled gcc
tried also remove gcc , reinstall gcc , and then dnf update work

when reinstalling gcc thereis a downgrade of libgomp and works

Sorry if this is the wrong thread but… will there be an update to allow the migrate script to update a server with secure boot enabled?

The migrate2rocky script will be updated to allow for secure boot. I know the maintainers are aware of secure boot now and it’s a matter of making a couple changes and testing.

3 Likes

Excellent news, thanks for the quick reply and confirmation.

Was able to get mine working this morning:

dnf clean all
dnf update

it then refreshed and worked. Without the dnf clean all, it was still causing the two problems to appear.

1 Like

dnf update --refresh
would probably also work.

I have a RockyLinux 8.4 installation obtained by migrating from Centos.
When I try to upgrade to RL 8.5 the transaction is blocked by the following error:

Error: Transaction test error:
file /usr/share/pixmaps/poweredby.png from install of rocky-logos-httpd-85.0-3.el8.noarch conflicts with file from package centos-logos-httpd-85.5-1.el8.noarch
file /usr/share/testpage/index.html from install of rocky-logos-httpd-85.0-3.el8.noarch conflicts with file from package centos-logos-httpd-85.5-1.el8.noarch

Should I unistall centos-logos-httpd-85.5-1.el8.noarch package before dnf update?

Checking my system I can found
centos-logos-httpd, Version 85.5, Release :1.el8 installed
rocky-logos-httpd, Version 85.0, Release :3.el8 available

Thanks for helping

Perhaps the migrate script should have done that replacement.
Is it supposed to, but did fail? If so, why?

I also assume that the migration script should have replaced the package.
I suppose the package only provides icons for http, for example those on the standard error pages, but I’m not sure.
The main problem is that the removal uninstal a lot of things, like httpd and php.

Also I don’t understand why the centos version is 85.5 while rocky 85.0

There is some alternatives?

Many thanks :heart_eyes:

I fix the issue with:
dnf swap centos-logos-httpd rocky-logos-httpd

More details here:

1 Like