Rocky 9.3 Cinnamon no bluetooth GUI

This is my first post to the forum so I hope i am following the rules.

I’ve just newly installed Rocky 9.3 with the Cinnamon DE.
All seemingly went well during the installation.

My system has an Intel AX211 wifi + bluetooth chip.

The wifi interface works perfectly and I can change networks via the wifi icon in the taskbar.

There is no icon for bluetooth. I can confirm that the bluetooth driver is installed and working. I ran the command:
(sudo systemctl status bluetooth)

and received this output:
bluetooth.service - Bluetooth service
Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset: enabled)
Active: active (running) since Thu 2024-04-18 21:21:59 BST; 59min ago
Docs: man:bluetoothd(8)
Main PID: 1287 (bluetoothd)
Status: “Running”
Tasks: 1 (limit: 407244)
Memory: 1.9M
CPU: 21ms
CGroup: /system.slice/bluetooth.service
└─1287 /usr/libexec/bluetooth/bluetoothd

I can’t find an application or GUI in Cinnamon to allow me to scan for and connect my bluetooth devices.

Any advice would be appreciated as I am a novice at linux.

Thanks in advance,

1 Like

You could try to install gnome-bluebooth.

dnf install gnome-bluetooth

I don’t know if this will give you the settings that you need, but it’s something to try.

1 Like

Hi Louis,

Thank you for your help. I installed the above without any errors.
After a reboot I unfortunately couldn’t find a bluetooth icon/applet in the taskbar and can’t find an app in the application menu with a name with blue or bluetooth in it. In the system settings I can’t see an option to check bluetooth settings either.

Thanks again though.

1 Like

Hi guys,
I just tried installing 9.3 with the MATE DE and I’m seeing the same.

I have bluetooth active, but there doesn’t seem to be a GUI for connecting devices.

I’ve tried many options such as trying to install Blueberry and Blueman
But those don’t seem to be available in the repos.

Is there a simple way to in stall a GUI for controlling bluetooth connections?
I’m quite a novice and Linux so any help will be greatly appreciated.

Thanks in advance,

1 Like