Bluetooth does not scan/stuck at scanning

Dear Friends…
I am using Rocky Linux 8.6
Kernel version is 4.18.0-372.19.1.el8_6.x86_64

For some time now, I have this issue in which the system Bluetooth can not be used to scan for new devices.
Kindly check this image and advise on how to get this working.

Best regards,

Hwllo @nmp .

I’m sorry, the Rocky project only supports the latest (current) minor release, which is 8.8. You can upgrade your system to it with a simple sudo dnf update command.

I’d recommend upgrading and retrying. This looks like it worked before, as I see devices listed there? Did something change? I’d recommend running dmesg and looking through /var/log/messages for bluetooth clues.


Hello @skip77
To answer your questions,

  1. Yes, it had worked before, and I removed my phone for some reason from the bluetooth list in the computer… I can’t recall why.
  2. /var/log/messages has a very long list of text, which has to be accessed in root mode and which keeps changing even as I open the file. I did that and found 530 instances of bluetooth. Can you please tell me what should I check there?

Or do you recommend me to just upgrade the minor version to 8.8, using the command
sudo dnf update
I hope this actually upgrades only to 8.8 and does NOT take me to Rocky Linux 9.0 land. Thanks for your inputs!

Yes, a dnf update will take you to 8.8. Jumping from Rocky/RHEL 8 to 9 is actually not supported, you’d have to reinstall.

I’d recommend updating, because not only will you get the latest security updates, but it may “accidentally” fix your issue.

thanks… I am using su command to login as root and then issuing dnf update command. It is updating - says 2.0 GB of d/l to be done in total, which I guess will take a little time after which i need to follow the instructions it gives me to update actually.

Hello @skip77
I am happy to report that the upgrade has solved my problem.
I have other issues which I have to glean the symptoms of before I put them up on the forum, but that is for another thread(s).

Thank you, I have marked your last reply as my problem’s solution.
Best regards,