Rocky 9.1 After last upgrading, the printer won't work

Hello! I was a convinced user of Centos, until the appearance of Stream. I welcome the arrival of Rocky Linux with great joy. I installed Rocky 9.1 as workstation and everything worked ok. Today I was informed that Rocky 9.1 installed some update packages. After this, my local printer stopped working. The message is that I don’t have the printer connected. But with the lsusb command, I find that the printer is detected. I really need to use the printer. Please help me. Thanks in advance.

A lot more information will get you a much better answer.

What printer? What does the cups configuration webpage tell you? What does lsusb actually say?

This is the data about the priter setting, which I currently have:
lsusb | grep -i laserjet
Output: Bus 001 Device 008: ID 03f0:2b17 HP, Inc. LaserJet 1020
hp-plugin & hp-setup.png
photo, which I want to attach, but I still don’t know how.

The cups screen you posted says “requires proprietary plugin.”

Have you installed (and perhaps activated, whatever is involved in that) the proprietary plugin ash shown there?

Thank You! How to install the proprietary plugin? With the command:
$ hp-plugin -i
Please, help me!

What have you tried and what steps have you taken to download and install the proprietary plugin?

At what point does it fail to install or not work?

I installed hplip using the command: sudo dnf install hplip* . Then I installed cups and activated it. Then, I gave the command hp-plugin -i (Rocky 9.1 still does not install the GUI) and followed the steps that the program asks.

First warning: Rockylinux distro is not found in AUTH_TYPES. Then what the screenshot shows.

I didn’t give up and installed: sudo dnf install python3*. (There are about 2600 programs). But I couldn’t print anything. I know that the printer is old (HP LaserJet 1020), but nevertheless, on MacOS Ventura, it works. It also works on Windows 11 and Linux Mint Vanessa. Am I the only unlucky one who, remembering Centos 5, 6, 7 and 8, I would like to use a distribution that preserves 100% tradition?!

Thank you for help! God bless you! I will announce the result as soon as I can.

Unfortunately, it doesn’t work. But is there anyone who managed to print something in Rocky linux 9.1, using an old printer, like HP_LaserJet_1020? There used to be, in Centos 5 - 8, a site, something like rkkda, which now I can no longer find on the Internet. With the program provided by that site, we install the printer very easily and correctly. And one more observation, in Linux Rocky 9.1 MATE (but only there!), I could print the first test page, then nothing. But Rocky Gnome doesn’t work at all. The message is that it does not detect the printer. I wonder; could it be because of the SELinux settings?

You uploaded the foo2zjs-z1 firmware to the printer as shown on that webpage and what happened after that?

You could print a test page from Mate so the printer does work. Can you print a test page from the cups webpage? If not, what was the exact error message or status message that you saw when you tried?

You need to give a lot more detail past a simple “it didn’t work” to get a useful answer.

After installing the plugin, I can print. But after I turn off the computer and the printer, it can’t print anymore. Only the message that it is being printed appears, then nothing happens. I get the selinux alert, as you can see in this snapshot, with the message below.

Did you run those two commands it suggested? This will allow what selinux blocked.

Yes. I gave the respective orders, but I’m unlucky: the printer broke down (simply, it’s not powered). I will repair the printer and I will communicate as soon as I have the printer working. Thank you from the bottom of my heart for your help. It seems that I need to know selinux much better!

It still doesn’t print. And when I enter the command hp-setup -g -i 001:008 (values ​​obtained with lsusb), I get the result shown below.

If it works when you first load the firmware and then not after you turn the computer off, that means you haven’t set up your computer to automatically load the firmware as part of the boot process.

In short, you actually have the problem solved. You load the firmware for that printer and it works fine. So all you need to do is set it up to run the command to do that automatically when you start the computer and you’re all set.

Thank You for Your help. Now I have to learn how to do it.

…“you haven’t set up your computer to automatically load the firmware as part of the boot process.”
How I can repair this situation?

There are numerous write-ups available with a google search that describe how to do this.

Here is the first one that I found: