Can not print to HL-3170CDW printer setup help

I’m new to Rocky Linux 9.4. I’m trying to install a print driver for Brother HL-3170CDW printer. I went directly to Brothers website and downloaded the driver file for hl3170cdwlpr-1.1.2-1.i386.rpm. Since I have not been able to print I’m not sure this is the correct file. Do I need to pick Linux (deb) or Linux (rpm)? What does Rocky Linux utilize? I followed the directions listed at the Brother website. I made edits to the /etc/printcap file as suggested but it seems to get over written. I want to use my wireless network so I need my config to reflect this. Any help with this installation would be greatly appreciated.

Thanks
John

You might not need the rpm from Brother’s website. The easiest thing is to go into the printer configuration and then look through the list of printers the system recognises by default from the standard packages that are installed.

None of the manual edits you are making should be needed, it should be enough to just add the printer choosing the model from the list.

Printing on Linux usually uses cups, so you can or should be able to go to your web browser as well and do:

http://localhost:631

Be careful with this, it says i386.

So I went in through Settings and tried to find a printer. I get 3 options when I type in my IP address. It comes back with

JetDirect-Printer
LPD-Printer
HL-3170CDW

When I try to select the JetDirec-Printer option, the software take me to vendor options. When I scroll through the list my brother HL-3170CDW is not in the list. The same thing happens with the LPD-Printer. For the LPD-Printer there is no HL-3170CDW.

If I select HL-3170CDW (Generic PCL6/PCLXL Printer) which is what I have and it tries to install a driver. The software says
“Additional print drivers needed” It appears like driver is there in the list but when I do a print test page it doesn’t activate the printer. For that printer listed I click on settings icon “Printing Options” → “Test Page”. When I click on the 1 job dialog box it opens a window which says Test Page Pending. All I can do is Cancel or pause but nothing comes from my printer.

Can you clarify exactly where you went from the cups home page

so it found your printer?

I see the cups home page. I did not make any selections from that page.

The driver that showed was from the folder icon at the top of GUI Rocky Linux 9.4 (Blue Onyx)->Settings->Printers. In the printers box on the right of page is listed a driver HL-3170CDW Model Generic PCL6/PCL XL Printer. I try to print a test page and it just says pending. When the driver installed it tried to look for additional software but message only appears for few seconds then it errors. I can go in and remove the driver.

I assuming you are wanting me to go to the http://localhost:631 web page. Can you be more specific as to how to use this page? I do have it open in my browser but there are many options. I’m assuming you want me to install the driver from the CUPs Home page. I need more specific direction with this? Thanks jwalker

OK, it’s clear now. Settings means Gnome Settings GUI, not the web based cups administration pages.

I was trying to work out how it could see your printer at all.

Yes correct. I assumed that is what was meant by the comment “the easiest thing is to go into the printer configuration and then look through the list of printers the system recognises by default from the standard packages”. Anyways with the current situation I still can not print. I’m guessing it tries to install some drive but it doesn’t seem to know where to find it. It states it needs more software but then goes to an error page. Hope this helps clarify.

I have to make you aware that my Wi-Fi settings had not been setup. My Wi-Fi is now set to my local network. I did a ping of my local network ip addresses printer and get return packets now.

Still unable to print - I tried to go back through the Gnome Settings. When I click on Printer Driver it does come up with my HL-3170CDW print driver and it installs the HL3170CDW Model Generic PCL 6/PCL XL Printer. A window pops up above driver saying “Additional Printer Drivers Required”. It says “An application is requesting additional print drivers” then below that is button “Find in Software”. I think it goes to the Gnome Software application to look for a driver but then it errors. It references “Unable to find Brother HL-3170CDW series you were searching for. Please see the documentation for more information”. Under “the documentation” link it lists under Package Kit missing items. One suggestion is to go to ELRepo site. Do I need to go find the driver at ELRepo?

I found these two links, I don’t like the look of either of them.

https://support.brother.com/g/b/faqend.aspx?c=us_ot&lang=en&prod=hl3170cdw_all&faqid=faq00100556_000

https://www.brother.co.uk/support/hl3170cdw/faqs/how-to-trouble-shooting/faq00100678_000

1 Like

Hi gerry666uk,

Yea! The very first link. I downloaded the tool and followed the instructions and I can now print. Thank you so much for all your help.

jhi

Let me know if I can or do anything else. Appreciate the support.

Hi Gerry,

The first link worked. I followed directions and am now able to print.

Thanks again for finding the link.

jhi

1 Like

That’s really good news.

I said I didn’t like the look of the links, trying to force i386 with x64, they should have re-compiled the driver, but on top of that, I don’t like binaries, I’d prefer to have the original source code (most official packages in Rocky are open source).

Yes, I agree it needs to be i486. I will try to contact the vendor and ask for this.

Thanks again
John