Rocky 8.8 is not compatible with jdk 1.5.0_22?

Rocky 8.8 is not compatible with jdk 1.5.0_22?
I installed jdk 1.5.0_22 on Rocky 8.8 and wanted to check the version
but it said…

[root@test bin]# ./java -version
There was an error trying to initialize the HPI library.
Please check your installation, HotSpot does not work correctly
when installed in the JDK 1.2 Linux Production Release, or
with any JDK 1.1.x release.
Could not create the Java virtual machine.

Hello @namwoo and welcome!

You’ve left out a bunch of information that will help people answer your question. The most important one is: HOW did you install jdk 1.5.0_22? What were the steps you used?

I’m probably not the person who will answer, but without that information, you’ll not get much of an answer. When asking a question in the forums, put in as much detail of how you got to the point where you are asking the question.

Are you sure you meant jdk 1.5? That went End of Life back in… 2009. Even the extended paid support for Oracle customers ended in 2015!