Problems so far

I’m NOT a Linux Guru, but I can find my way around with a GUI interface and VERY basic command line.

I want to update my servers from CentOS 7 to Rocky (or Alma).

I installed Rocky on one of my VMware servers.


  1. Setting the screen resolution is not persistent. If I shut down the box, when I restart I’m back in 800x600.
  2. I’ve been trying for a week to get Apache virtual servers working with ZERO success.
  3. Centos 7 had a nice GUI that I could use to create users and assign them to groups, change their passwords and suchlike and that’s gone to be replaced with the shitty gnome one that’s quite useless.

APACHE Virtual Servers
I’ve been to 3 different ‘HowTo’ sites, all different, none work. Apache is working fine, I’ve disabled SELinux (pain in the ass). I’ve made sure the firewall is open for Ports 80 and 443.

I tried the same .conf files that I used for Centos-7. Thay didn’t work. I tried the conf files in the other sites I’ve been to and they don’t work either.

My working one was:

<VirtualHost :80>
ServerName server1.Mydomain
DocumentRoot /var/www/server1
RewriteEngine on
RewriteRule ^(/server1.
) /www/server1$1
ServerAdmin My Email Address
ServerAlias server1
ErrorLog /var/log/httpd/server1-error_log
TransferLog /var/log/httpd/server1–access_log
DirectoryIndex index.php

This was in /etc/httpd/conf.d

I’ve tried 3 different ones from ‘HowTo’ sites. All I can get is 404 errors or apache refuses to start with errors. (so much for HowTo’

Can anyone get this working? I only use the servers to host websites. In house NOT via a Hosting site, so I have 100% access to everything.

For errors with apache, use:

apachectl configtest

it will tell you what errors are in the config files - usually because of typos or incorrect entries, maybe even directories mentioned in the vhosts don’t exist, eg: /var/www/server1 hasn’t been created yet. The command will tell you what you did wrong.

From above your config does seem to be missing </VirtualHost> at the end of it - now whether this is because it wasn’t copied here, or whether it’s actually missing in your config file, I don’t know. But the configtest command will tell you if that is the case as well.

Be very careful about copying config files from one version to another - it’s best to actually just copy the parts you need, eg: the VirtualHost part, rather than the entire file. As they can usually be specific for the distribution you are using. Unless of course you created your own config files and put them in /etc/httpd/conf.d then they would generally be safe, but may need fixing in case directory paths changed, etc - like I already mentioned above.

Good Advice, I got it working. Thanks

1 Like