No sound on recent-ish hardware

Hey guys,

So, there’s been a pesky problem I’ve been trying to fix wit no success. Essentially, the problem is this:

  • I have a MSI B550M Bazooka motherboard with a “Starship/Matisse” sound controller [1022:1487];
  • It works fine on Kernel 4.18.0-348.23;
  • I need the NVIDIA drivers for work;
  • The NVIDIA drivers can only run on 4.18.0-348.20;
  • My onboard sound controller doesn’t work on 4.18.0-348.20 for some reason.

I’ve tried almost everything short of recompiling the kernel, but that would be totally unreachable to me, not only because it’s been many years since I did anything like this but I truly don’t have the time.

I’m currently on Ubuntu 20.04 as it’s the most compatible with Maya (aside from Rocky/RedHad), but it’s truly a miserable experience here, not only because KDE 5.18 doesn’t work well with a graphics tablet, but I’ve only managed to get Maya 2022.3 to work, which is buggier and a lot slower than 2023 in many operations I do daily, which is the version I was working with.

If any dev reads this thread, I believe I found a patch that could work: Has anybody gotten audio working in Linux on Aorus X570 Master? - #79 by gladiac - Linux - Level1Techs Forums

If anyone could help, I’d immensely appreciate it.

Which NVidia drivers those are? RPM-packaged by NVidia, RPMFusion, or ELRepo – or the unmanaged blob from NVidia?

ELRepo version of package strips kernel version dependency; same driver works with every 4.18.0-348.x, so one driver per point update.

The NVIDIA ones. I install them with:
dnf config-manager --add-repo
sudo dnf install kernel-devel-$(uname -r) kernel-headers-$(uname -r)
sudo dnf install nvidia-driver nvidia-settings
sudo dnf install cuda-driver

I tried installing the 4.18.0-348.20 Kernel beforehand, installing it’s “kernel-devel” and “kernel-headers” packages before installing the NVIDIA driver, rebooting, then installing the NVIDIA driver, but no dice.

As a matter of fact, I just re-installed Rocky, installed this 4.18.0-348.20 Kernel, and it had no sound. So I believe it’s not related to the NVIDIA driver.