NixSysAdmin this is for you!

awhile back you posted some (excellent) advice on a post I had (RL9.3 how to move /home)
Life and work got in the way, and I did this over last weekend. Worked like a charm, until it didn’t…

After I completed the steps, it worked perfectly. I was able to copy over the files that were previously too large and the server ran fine.

Today, after it’s been running for roughly 1.5 weeks, I needed to change something on esxi so I shut down the vm’s (this one included of course) and when I restarted it, it throws me in maintenance mode now. :frowning:

journalctl for ‘failed’ reads as follows:

Any idea what might’ve happened? I mean it worked great up until the reboot!! lol

I speculate and could be wrong but I think what happened is that selinux was disabled for the relocation of home. When you rebooted selinux reverted to its operational state and this file was missing:

.autorelabel

Thus preventing the file system to be read. The solution would be to reboot and edit the kernel commandline to add selinux=0 for this boot, then add the empty dot file

touch /.autorelabel

Then reboot.
I could be wrong but I know someone will correct me.

Gave that a shot, I (think) I edited it properly, on boot, I hit ‘e’ to edit, added the selinux=0, hit f10 (also tried it again hitting ctrl-x) signed into maintenance mode and did the touch command.

Rebooted it to the same result. Further looking around though, I think I have selinux disabled. I checked “sudo nano /etc/sysconfig/selinux” and already had selinux=disabled.

Another thing I notices, when I go to /home all the files are there that I copied over, so it “is” seeing them okay, it seems… Not sure exactly why it’s keeping me in maintenance mode and why it times out…

Thanks in advance,
MTXRooster

Hi,

Where did you add it? needs adding to the end of the linux line just after quiet.

Regards Tom.


I have to put it there each time I hit ‘e’, it does not save (is that normal) - To continue from there as the prompt indicates I hit ctrl-x or F10 to boot. (I don’t hit ctrl-c or F2 or escape to discard)… Should I do this through the ctrl-c/F2?

You put it at the end of the line that starts with linux the fourth line on that screen. Putting it at the end like you have done it will not take effect. The end of the Linux line is where it says lvm.lv=rl/swap so it goes after this (do not make a new line just lvm.lv=rl/swap selinux=0).

1 Like


Put it here, executed the same touch /.autorelabel command, shutdown -r to restart and back to maintenance mode :frowning:

I can reimage this machine, it’s not critical, I’m just trying to get a better understanding of what might’ve gone wrong with it. Especially since everything was working great after the inital partition resizing etc. :slight_smile:

Perhaps try doing an:

lvchange -a y

when booted in rescue mode, just in case one of the LVM’s has become inactive.

Have you tried selinux=0 ?

1 Like

Hi @Xino,
It might not be related, yet still: you have a typing erro in the shown picture: selinmux instead of selinux

Heh, indeed, but that was a second (or 3rd, 4th…) attempt, where I mistyped it ironically for the photo…


After doing it right (as before) this is where it stumbles:


The final result:


and the journal with grepped failed:


I really can’t imagine it being selinux, because it is disabled on this system, but who knows… :frowning:

Sorry for all the posts in a row - Even though I’ve been here for well over 3 months (2+ for sure) it still considers me a “new user” and get a whopping 1 pic per post :frowning:

Shut down the server. Boot it from a live disc.
check #lsblk
Without mounting the server’s file system in the running system, do a repair xfs_repair ‘device from list named /home’
Then repeat the step with again ‘.autorelabel’

" It might not be related, yet still: you have a typing erro in the shown picture: selinmux instead of selinux"

This is the idea!
To show the error that says nothing happens.
When the questioner reads and understands the constructive criticism without loud words - that is quite enough.

:wink: