Cant enable selinux

I am unable to enable selinux. I have SELINUX=enforcing in /etc/selinux/config.

sestatus shows disabled even with enforcing on. If I run setenforce.

rpm -qa kernel

It’s a bit strange, because the default is “on”, so did you mess with it at some point?

I have not changed anything; I have tried to auto relabel, and I have tried to restore from backups with no luck.

Can you explain a bit more about what led up to the problem where you needed to relabel and restore from backups?

Can you also post full output from ‘sestatus’

And output of cat /proc/cmdline

root=/dev/sda console=tty1 console=ttyS0 ro devtmpfs.mount=1

prior to attempting the relabel when I would enter sestatus even when /etc/selinux/config was enabled.

SELinux status:                 disabled

Is this some sort of VPS you have? If so, what service? There should be no cases (with the exception of certain VPS or the user changing their system) that SELinux should ever be permanently disabled.

This server is hosted on linode.

This has been resolved by changing the kernel to Grub 2 in the linode server manager. Im not sure why linode disables selinux in the kernel.