Mongo db service not started on Rocky Linux 9

Mongo DB version 6 installed on Rocky linux 9 server but the mongodb service is getting failed not started

Active: failed (Result: core-dump) since Thu 2023-07-20 14:00:13 +04; 4s ago

Monogo db version 6 can support Rocky linux 9?
Please give me solution foe this issue.

As of MongoDBs documentation Rocky 9 is supported:

Thank you for responding!!

Yes, I have inatalled used the above official link only.
But the service is not started getting failed on my vm. I have tried with another vm on rocky linux 9 there also getting the same error.

Could you check the system journal (i.e. journalctl -r) if there are any other messages, the one in the screenshot does not really tell a whole lot (don’t have access to a system right now)

Seems strange, I’ve just followed this: and installed MongoDB 6.0.8 on Rocky 9 and it just worked. The only things I did were:

nano -w /etc/yum.repos.d/mongodb.repo
dnf install mongodb-org
systemctl enable mongod
systemctl start mongod

the first command I pasted the repo config, the second installed MongoDB, third and fourth enabling and starting mongod.

What cpu/ram has your VM/server got? Mine is 2cpu, 4gb ram. Yours seems to have core-dumped for some reason, but the logs @lumarel asked for may explain more.

MongoDB seems to be the problem here, you would be better asking on the MongoDB forums since this is a MongoDB problem, not Rocky. Help here could be somewhat limited, depending on the type of error appearing, and how many MongoDB experts are here. Check your VM/server requirements are enough first in terms of cpu/ram/disk, and then we’ll see based on further logs provided by you.

Another possibility that I found with google is that if you had MongoDB 5 installed, then changes between 5 and 6 could also cause this. Or perhaps this: Status of Mongod returns core-dump - Installation & Upgrades - MongoDB Developer Community Forums

1 Like

Okay Thank you @iwalker
have a great day!!!