Rocky 9 Latest - Problems with SSSD - Won't Start - Cannot Join AD

Hi All,

I have a rock solid script for joining Rocky Development workstations to active Directory.
I am following the script with the latest ISO as a boot medium and its fails. Whereas once it succeeded no issues.
The problem seems to be related to SSSD which wont start. There is no config file to start the default service.

Any ideas?

It would be helpful to know what you are running (e.g. what commands) to join the domain. A sssd.conf is created on a successful join.

OK - Great this gives me something to work on.

Thanks for your reply.

I am having to use a mod to krb5.conf to allow some older enctypes again this worked before.
realm join xyz.local -U username

I’ll look at the kerberos logs next

What worked before now returns REALMD_OPERATION=r1428.2965 realm couldn’t join realm: Failed to join the domain please check

Please close this ticket :slight_smile:
There are several idiots this end - me being chief idiot.
Documentation updated.

Realm join user -U needs no @domain.local

DO NOT read posts from other users saying that SSSD is broken in 9.x and make any assumptions they know what theyre doing either. Classic opensource support conundrum,

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.