Missing directory from subscription-manager install

Not sure if this is a Rocky issue or if it’s a RHEL issue, but it at least only seems to affect Rocky 9.1 at the moment.

Issue i’m having is that the subscription-manager package should create a ca directory under /etc/rhsm, but on rocky 9.1 it doesn’t get created ( /etc/rhsm/ca ) Which breaks provisioning a Rocky system under foreman/katello.

this worked flawlessly on rocky 9.0, and works fine for RHEL 9.1

In 9.1, the subscription manager packages separated out and you’re likely hitting something our automatic patching didn’t consider. Try also installing subscription-manager-rhsm-certificates and see if that alleviates the issue. This will be fixed in subscription-manager-1.29.30-1.el9.0.1 which should show up in mirrors in the next few hours (where it should require the aforementioned package).

Package ‘subscription-manager-1.29.30-1.el9.0.1’ now has dependency 'subscription-manager-rhsm-certificates` which is good. But package ‘subscription-manager-rhsm-certificates’ is now missing in the repo…

Odd. It should be there. I refreshed baseos, so maybe that’ll kick it into gear.

[root@firemonitor ~]# dnf install subscription-manager
Last metadata expiration check: 0:10:19 ago on Wed 30 Nov 2022 08:37:31 AM MST.
Dependencies resolved.
 Package                                                Architecture           Version                            Repository              Size
 subscription-manager                                   x86_64                 1.29.30-1.el9.0.1                  baseos                 763 k
Installing dependencies:
 libdnf-plugin-subscription-manager                     x86_64                 1.29.30-1.el9.0.1                  baseos                  78 k
 python3-cloud-what                                     x86_64                 1.29.30-1.el9.0.1                  baseos                  87 k
 python3-ethtool                                        x86_64                 0.15-2.el9                         baseos                  40 k
 python3-iniparse                                       noarch                 0.4-45.el9                         baseos                  42 k
 python3-inotify                                        noarch                 0.9.6-25.el9                       baseos                  52 k
 python3-librepo                                        x86_64                 1.14.2-3.el9                       baseos                  49 k
 python3-subscription-manager-rhsm                      x86_64                 1.29.30-1.el9.0.1                  baseos                 164 k
 subscription-manager-rhsm-certificates                 noarch                 20220623-1.el9                     baseos                  20 k
 usermode                                               x86_64                 1.114-4.el9                        baseos                 175 k
 virt-what                                              x86_64                 1.25-1.el9                         baseos                  32 k

Transaction Summary
Install  11 Packages

Total download size: 1.5 M
Installed size: 5.2 M
Is this ok [y/N]: n
Operation aborted.

Just updated baseOS and retried, and now it works, thank you