Migr. from CentOS7 just now due to drivers for HighPoint RockRaid rr2340

Hi!

I’m running CentOS7 with its latest existing update but now have found drivers that are patch and should work on kernel > 4.17 so I’m about to move to Rocky Linux.
The RAID-card using RAID5 is used for my big storage but the system disk and all other partitions are on RAID1 and encrypted, which I off course has the key to.

I know wonder if your script will work on this system? cos I really need to get machine more up to date.

I added more storage to the RAID5 a couple of weeks ago and then saw that I had to convert the filesystem to handle 64-bit inodes due to the size of it. This led a to a problem for me as the convert tool (used by gparted, can’t rememer the name of it) couldn’t handle that so I needed a newer one and that wasn’t easy. The latest version didn’t work but I found another one that had the same problem so I did what he did and got the source for the convertion-tool as old as possible but with the option to do this and compiled it and lucky me it worked.
All this made me think I got to get up to a newer kernel and such and this place is what I’m thinking to going with. There are other CentOS-clones but I trust this the most as the creator is the creator of CentOS.

I read somewhere that I need to upgrade to CentOS8 first but other says that this step is useless so what do I do? if this is meant to be the non-stream version, there is no repo that I can find that has those files left, they all seem to have removed them.
One thing I tried said that it will not handle encrypted devices and that is also a big hassle.

If more info is needed, please ask

//B52

I got my drivers to compile in 4.18 after a little fiddling in the source.
My new problem is with kernel 5.17

As I compile the them it gets to a point where it can’t find a file:
/Documentation/Kconfig.
I look that up and it seems that in 5.x they introduced this and it’s necessary to have this to be able to continue, the problem is that I can’t find the SRPM for this anywhere.
I found one SRPM but that was just some 160k big and didn’t have these files and directories in it.

Do anyone here know where I can find that so I can compile my drivers for kernel 5.x?

Rocky doesn’t use “5” series kernels and even Fedora hasn’t adapted 5.17 for their F35 release yet.

Yeah, that I know but I’m trying to be proactive so I know it’ll work when that time comes or alteast gives me less time to set it up.

Saw a page how to fix this and as I’ve understood it the changes in tihis Documentation/Kconfig seem to have stoped after 5.x something so I grabbed a SRPM from elrepo, 5.17 and gonna test that when I get off work. Saw a place that said to place the Documentation dir under /usr/src/kernels/

I’ll get back with result later.

PS. btw when does the kernel interface change?
is that only when the major number is changed? like from 4 to 5, cos I’ve had problems with compilaton within the old 3.x it runs on now.

Well as far as I know EL8 will continue to the end (2029) with the 4.18 kernel. I don’t know what EL9 will use.
I haven’t compiled a kernel since 2010 so I’m not up on what version of gcc you need to use for each kernel era, but I’m pretty sure that you need the gcc version that was common for the 3. kernels and that may be true for the other libraries.

OK, but I won’t compile the kernel, just the driver module from the RAID card but it seems that this is needed with kernel 5.

CentOS Stream 9 names kernels: 5.14.0-nn
A decent guess for EL9?

Ah OK, got this 5.17 frim elrepo and they are on the edge so…

Good to know, elrepo also has 5.4 so I could try build the module for that insted.