Login Screen Hangs on boot

I have installed Rocky Centos 8.5 x86_64 DVD ISO on an HP DL 585 G7 server with 4 AMD Opteron 6174 processors. The installation went fine, and the network is fine, but the login screen hangs, and I have not found any way to fix this problem. I tried re-installating Rocky Centos 8.5 first selecting a “Workstation”, and then I tried “Server with GUI”, Both hang. I have tried restarting gdm, “systemctl restart gdm.service”, ( also tried stop and start instead of restart, but no difference ) but that does not help. The network comes up fine after the first boot, so I can ssh into the installation. I have searched for solutions to this problem, and have not found anything that works. I saw the same problem in a Red Hat 8.5 x86_64 installation, but Red Hat support was not much help, so I am now trying Rocky Linux and seeing the same problem. I have Centos 7.9 running on an identical server, and it does not have this problem. If anyone know this problem, and knows the solution, I would really appreciate your suggestions. Thanks, Jim Email: jimwest@attglobal.net

They differ only in the list of packages that are installed; the GUI packages are the same.

You can run systemctl set-default multi-user.target
That makes the system to go to text-mode on boot.

You can run:

systemctl isolate multi-user.target  # to switch the running system to text-mode
systemctl isolate graphical.target   # to switch the running system to GUI-mode

Graphic freezes are usually related to GPU and its driver. Error messages could be in

Ah!! You too. Trivia question: When you login are you using Wayland or X11?? Red Hat decided to make life difficult by adding both Wayland and X11 for each DE. If you are using Wayland you will get the hang. Use the X11 version of the DE and it should work just fine. Wayland is NOT ready for prime time and including it in a distro is a recipe for disaster. Here is a quote from the latest KDE update:

Fixed one of the ways that the kded daemon could crash in the Plasma Wayland session (David Edmundson, Plasma 5.25).

Notice it said one of the bugs. When it says “crash” they are talking about hanging the system. Red Hat may think they are cutting edge – and to some extent they are – by including Wayland as a choice or jumping from Grub2 to /boot/loader/entries but in their haste to drive technology forward, they break something that USERS have come to depend on. If some USER wants to play around with Wayland they should be forced to download from some site, but it should NOT have been included in the main distro; likewise screwing with GRUB2 and going with this /boot/loader/entries which is Non-standard. Doing so breaks things that look for a specific Grub2 order, which it no longer finds.

BTW you may discover that if you boot in X11 it will work fine, but if you boot it a second time you will end up in an endless login loop. The solution is to boot into Wayland – which will cause your machine to hang – and then login back in to X11 once again and it will work once again just fine. In short the X11 version of the DE works fine; the Wayland version does not and causes the machine to hang. I suspect that Wayland overlaps with X11 which if you boot the machine a second time in a row causes the a X11 login loop. As KDE said they found one bug which implies thee are a lot more in Wayland. Red Hat should have stuck with X11 and allowed USERS to download Wayland and play with it if they so choose – if it blows up their machine, so be it, but including Wayland in the main distro?? BAD idea.

1 Like

Thank you for pointing me to the /var/log/Xorg.0.log file.
I found something interesting on this problem.
When I installed the Rocky Linux 8.5 iso into VMware Workstation, and booted it up as a virtual computer, it booted fine without any problems on the exact same server, HP DL585G7.
The same iso hangs on boot bringing up the login screen.
I found that I can work around this problem by logging into the machine, and running /usr/bin/Startx. That works fine, and bring up the same desktop that the virtual machine brought up.
I really prefer the desktop used by Centos 7.9…
As a separate question, is there any way for 8.5 to present the same desktop the default Centos 7.9 desktop.
In the Xorg.0.log file, I found:

2956.352] (EE) AIGLX error: dlopen of /usr/lib64/dri/radeon_dri.so failed (/usr/lib64/dri/radeon_dri.so: cannot open shared object file: No such file or directory)
[ 2956.352] (EE) AIGLX error: unable to load driver radeon

I am using an HP DL 585 G7 server. All HP DL 585 G7 servers include an embedded ATI ES1000 VGA controller. The ATI ES1000 uses a Radeon Processor. The Radeon driver in Redhat 7.9/8.5 is not the right Radeon Driver. The HP DL 585 G7 bios supports an optional VGA controller. I bought a GeForce 410 VGA controller, and configured the bios to use the GeForce VGA driver as my primary video controller. The GeForce VGA controller works great in RedHat/Centos 7.9. That solved my problem. Now when RedHat/Centos 7.9, it brings up the X11 login screen, and everything works fine. The Radeon VGA driver in RedHat/Centos 7.9 is the wrong driver for RedHat/Centos 7.9.

1 Like

I’m not sure your issue is clear. In your first post you mention Rocky CentOS, Rocky is not CentOS, and CentOS is not Rocky, so it’s either Rocky, or it’s either CentOS. Also in your subsequent posts you confuse with what is or what isn’t working with Red Hat/CentOS. You cannot compare RHEL/CentOS 7.9 with RHEL/CentOS 8.5 - it’s not the same thing.

Since Rocky is based on RHEL, if the problem exists in RHEL then it will exist in Rocky as well. If the drivers included by RHEL don’t work, then it will be the same in Rocky. Also the driver that is by default in RHEL/CentOS is not necessarily the wrong driver - chances are it works for others that potentially have older hardware. Maybe you have newer hardware and this is why you experience problems.

So in which case you need to be installing the ATI drivers separately just like everyone else does with NVidia. I don’t know if they exist in a repository like they do for NVidia in ELRepo. So you need to be installing the driver separately.

This reminds a lengthy thread on CentOS Forum: Centos 8.5 ISO boot issue. - CentOS
Different Jim?

The “ATI ES1000” has existed since 2005 or so. No real wonder if it lacks drivers and features today.