K3B : can't burn audio projects


I’m running Rocky Linux 8.7 with EPEL’s KDE on my main workstation, and everything works fine… except one little detail that’s nagging me. K3B can’t seem to handle audio projects. Whenever I start an audio project and click on Burn, K3B stops short and nothing happens. Sometimes I can’t even close the window and I have to kill -9 it.

A peek in /var/log/messages shows this, I don’t know if it’s the culprit:

Feb  1 08:49:46 alphamule k3b[2637]: QIODevice::seek (K3b::AudioTrackReader): The device is not open
Feb  1 08:49:47 alphamule k3b[2637]: QIODevice::seek (K3b::AudioTrackReader): The device is not open

What’s even weirder, I have a sandbox machine in my office with a (what seems to be) identical installation of Rocky Linux with KDE, and on this machine, burning audio projects with K3B works perfectly. So I thought it was a hardware error. I swapped the DVD/RW devices, and I got the same result.

I’m puzzled and clueless.

I just booted a KDE Neon LiveCD on my workstation, ran it in live mode (plenty of RAM so no problem), installed K3B and a handful of other apps for testing purposes and gave burning a spin. The good news is that it’s not a hardware problem. Audio playlists with .ogg, .mp3 and .flac files can be written to CD correctly.

So it looks like EPEL’s K3B is the culprit.

I built a more recent K3B from a Fedora SRPM, and still got the same problem.

In the end I just wiped K3B from my hard disk and replaced it with Brasero. Somehow I hated doing this since I’m not exactly a friend of GNOME. Fortunately it’s one of the rare GNOME applications that doesn’t pull in the whole GNOME kitchen sink, only a handful of dependencies for handling burning and playlists.

Things work perfectly now, so problem solved. Sort of.

On a side note, it’s a bit sad since I’ve been using K3B for the last twenty years or so, and it’s always been one of KDE’s must-have applications.



It’s funny you should say this, I had a similar situation, albeit the other way around. Linux Mint I think with Brasero kept failing and crashing on me, destroying disks as well when I attempted to make them. And switched to K3B.

That said, I believe I had issues with K3B and audio when I was missing some dependencies. I did fix it, but I cannot remember what audio dependencies it needed. It was a long time ago when I experienced this. Perhaps that one particular install is missing an audio package that is required for K3B and it’s audio projects. The only thing I can suggest, would be to compare your installed packages between the machine that works, and the one that doesn’t.

Sorry I cannot remember exactly what I did in a similar situation, this must be like 6 - 10 years ago, so hope that might help a little bit at least.

1 Like

Is there any more followup on this? I’m having the (apparently) same problem on Rocky 9.1, in which it won’t burn audio CDs, but just hangs after claiming to start writing.

I CAN burn the very same file to a CD by manually invoking cdrecord.

I have NOT yet tried burning a non-audio file/ISO yet.

Not finding much info on the net about this, so far, so if any of you have more info I’d love to hear it.

Thanks in advance!


1 Like

OK, burning a data CD works fine!

I also tried brasero, which doesn’t work either: it complains that cdrecord isn’t installed. But it is! right there in /usr/bin is cdrecord. true, it is a symlink to /etc/alternatives/cdrecord-wodim, but so what? why would that matter? when I do a burn from commandline using cdrecord, I only specify “cdrecord”, and “which cdrecord” says “/usr/bin/cdrecord”, so we know it works.

I’m stumped. anyone got any good ideas?