Cant update new rocky 9 kde install successfully

I just installed rocky 9.2 KDE on one of my desktop computers. Upon intallation, i tried to update (using yum) and I got over 90 errors suggesting I needed files that were not available. I have rocky 9.2 on a couple other of my home computers. Now when I try to update thase systems, I get the same errors. WHAT is going on? Using the discovery tool, when complete I cant get ANY of my applications to load and can’t reboot or shutdown without unplugging. When I do this and try to reboot, the system stalls. It looks to me like a new set of updates was put into service incorrectly. Please advise.


Rocky Linux 9.3 is not yet released. Until it is released, you won’t be able to perform any KDE updates from EPEL.

1 Like

Red Hat Enterprise Linux Release Dates - Red Hat Customer Portal shows that RHEL 9.3 became generally available 2023-11-07.

The EPEL (Extra Packages for Enterprise Linux) has already (re)built and released packages for EL 9 (so that RHEL 9 users can update their systems, including EPEL content). No mistake there. (There would be many unhappy users, if EPEL would wait until every RHEL 9 -like distro reaches 9.3 content.)

I do have EPEL repo disabled by default and enable it only for explicit transactions. That way I won’t accidentally use it during point update release twilight zone.

Is it recommended to disable EPEL until then?

Thank you that is exactly what I was going to do. Lucky this did not disrupt other Rocky KDE systems I was relying on.
I am not used to having to rely this deeply on OSs.

So, I have already made the mistake of trying to get KDE to work, and now I cannot “downgrade” to the system I had before I did this. Was not thinking clearly, and now I’m somewhat hosed.

I see two options, one is to find the packages (166!) that I did “upgrade” on the web (and download them one by one, and the other is to launch a VM based KDE iso “live desktop”, and download the rpm’s from within that (which is where I’m headed now). If there is an easier way, I’m all ears.

I unfortunately am completed married to KDE, and hate GNOME, which is what I’m working with now to do the repair. If someone has a better way to do this, I’m all ears. Even if there is a site I could do a “curl” from, and get all 166 packages via a script that would be a major step forward.

Thanks much!

1 Like

And, that didn’t work, at least as far as I can tell.

I have a VM that works, but there are no package RPM’s available, and this system is in the same state my main system was before yesterday. Has a bunch of packages it can’t install if I do a

dnf update

It looks as if I’ve an enforced penance of having to use GNOME till 9.3 is avalable.

Still hoping that there is a “magic” repo, or http site (that I could trust) to get those back…


1 Like

Theoretically you can do:

dnf history --reverse

find the number that relates to the point you want to return to, eg: the update that you pushed that has failed, and then:

dnf history rollback <number>

where is the transaction ID from the first command. Obviously you want to be sure which transaction by not going back too far.

Thanks much, but the issue was the underlying rpm’s did not exist. I did know the exact numbers/etc., I could even find them, (or files with those names, as I’m not getting them from a source that’s Rocky, or EPEL, or…) but it would be downloading them one at a time. The biggest thing was, however, is that I couldn’t verify they were truly the correct RPM’s.

However, I just was able to do the upgrade to 9.3, and erase and reinstall KDE, and it all is looking good again.

Also, I had a chance to check out XFCE, which was not bad, but not as “fully featured” as I liked. But better than GNOME at least as far as I could see.

But really happy I’ve got KDE back, and have the “newer” Rocky.

Thank you the “history” command, I’ll play with that. I got the exact package names by looking through the log files, and editing… That would be much more straightforward.

Much much joy!


I tried to the same with konsole. Deleting it and reinstalling it, but I still get the same error messages even after an update to 9.3.


So, I did a

dnf group erase KDE
dnf group install “KDE (K Desktop Environment)”

Logged out, and logged in again, and it was all back. I’m pretty sure you need to get the whole thing, (which includes konsole). I did have to erase the group to clear things out.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.