Is Ceph support coming to Rocky Linux?

Does anyone know if there is an effort in progress to support ceph in Rocky Linux ?

There is option to enable CentOS SIG repos for now. Did they have ceph?

dnf search ceph
centos-release-ceph-nautilus.noarch : Ceph Nautilus packages from the CentOS Storage SIG repository

dnf install ceph

ceph-deploy install cephmaster ceph1 ceph2
[ceph_deploy][ERROR ] UnsupportedPlatform: Platform is not supported: Rocky Linux Green Obsidian 8.5

I have also tried ceph-ansible and eventually get the same results. I also tried the cockpit-ceph-installer with no luck either. I know ceph is complicated so I just may be missing something.

I’d guess that “ceph deploy/ansible” have list of “known platforms” and what to do on them.
They just lack the string Rocky and the fact that it is practically identical to certain other known platforms.

Upstream Ansible had similar issue, that got patched.

Where does CentOS SIG get Ceph sources? From upstream Ceph developers? Logically, a patch request should go up there.

In the meantime, I’ve heard that some programs can be fooled by editing /etc/*-release. No idea how terribly unwise that is.

When I tried ceph-ansible I had to edit alot of files to add “Rocky” as an acceptable distro to yaml files. I finally ran out of files that I could figure out where and how to edit. I tried looking at the release file and several commands that the OS name and version could be gleaned from but to no avail. I came to the same conclusion that I may be able to trick the installer by editing a file, I just haven’t found it yet.

I not sure what the source for CentOS SIG is but I have tried other repos. I tried a site called I did get a little farther but their software is so branded I had to abandon it because I’m not running their hardware. It was either that or spend the next several weeks editing python code. Its is a very clean cockpit based GUI though.

According to their issue tracker the string was added

But not for Nautilus as its EOL it looks like:

And my understanding is that Ceph-Deploy is not supported/recommended for RHEL 8:

Have you tried using cephadm? My understanding is that that is the recommended and supported way to install

Im not a ceph admin but have been looking to implement it for a little while now. Curious to hear your progress

Using Nautilus may have been the problem. In my many installs I kept seeing that Octopus was not supported. So I kept removing everything Octopus in favor of Nautilus. I know when I installed cockpit-ceph-installer it really didn’t like me using Octopus.

We have alot of customers interested in Ceph and we want to make it work on Rocky but my time may be running out. As I have been working on this for several weeks my endeavors may have to take a slower pace because of priorities. We may end up turning to a commercial solution.

Thanks for the links. If I make anymore progress…or not. I’ll post it.