How do I ENABLE right click on my touchpad and how do I copy content into the terminal?

I just installed Rocky Linux because I like that it is the kin of centOS and is bug for bug RHEL. I can not right click using my trackpad on my computer. I need to do this to copy long commands into the terminal. The terminal also does not allow me to either right click or copy content into it using ctrl+c and this is frustrating. I can not imagine a computer with out right clicking. How can I fix this?

Hi @noah_qayain I’ve noted this same behavior on my laptop. The very first thing I do with a laptop, though, is go pick up or connect an external mouse, as I’ve never been a fan of the touchpad. That said, assuming a vanilla install with GNOME, I believe this can be fixed with gnome-tweaks (dnf install gnome-tweaks). Once installed, go to “Activities” and then type “tweaks” in the “type to search” field. Once found, click on it and then go to “Keyboard & Mouse” and look at the settings in the “Mouse Click Emulation” section. I’m guessing what you are needing to enable is the “Area” setting, rather than the default “Fingers” setting.

This was a setting change by GNOME to the default behavior of the touchpad some time ago, and you are not the first person who has run into difficulty with it.

Good luck!
Steve

1 Like

Thank you! This helped me solve my problem and I learned something as well. Much thanks! Baruch Hashem!!!

I believe the default is multitouch. For example my touchpad is one big button, rather than having separate left and right click buttons.

  • If I click the touchpad with one finger it’s a left click.
  • If I click the touchpad with two fingers it’s a right click.

I also want to note that the in Rocky 9 the Gnome settings app’s Accessibility settings has a “Simulated secondary click” feature.

If you hold down left click, after a second or so you’ll get a right click instead:

Simulated right click example Screencast from 2023-01-22

1 Like

Thank you for the illustration maim.