Firefox Bookmarks Toolbar Invisible after update

This is a new rocky install as of probably a week ago. Today I ran software updates and one of them was a firefox update. I had set up my bookmarks and extensions already. After the update I had to toggle the extensions off / on for any of them to work again, and my bookmarks bar is now blank. The bookmarks still exist, but they are not showing in the toolbar at all.

@RenegadeSoup What Rocky Linux version did you install 9.1 or 8.7? Also, what is the version of Firefox that shows when you do help, about? For instance, I’m running 9.1, it is fully updated, and my Firefox version is:

Extended Support Release
102.7.0esr (64-bit)

All of my extensions and plugins are fine (I didn’t have to muck with them) and the bookmark toolbar is there and functional.

If you right click on the ‘Tab’ row it will show a drop down menu where you can turn it on again. I prefer the old style with top row menu and always visible bookmarks tool bar there also selectable on the right click menu.

I’m running Rocky Linux 9.1 with Firefox 102.7.0esr (64-bit)

after doing some more digging (and tweaking my search terms) I ran across a help page that described something similar to mine.

The recommendation was to go to Firefox help > More troubleshooting information > and run the “verify integrity” function under the places database.

That has seemed to fix my issue.

1 Like

Showing and hiding the menu didn’t change anything. When I would show the toolbar it would expand the space where they were supposed to be, but they would be blank.

I did find a fix and post it in this thread though.