Even More Adventures of a Vacuous Experimenter

I’ve been digging DEEP into my Bag of Tricks with mixed results. I was able to get KDE to actually boot by switching to lightdm, with one small little fly in the ointment: The font blew up to 1024 x 768 resolution and my BenQ monitor was not even recognized. Some of the other DE also worked but the same problem persisted. So I gave Rocky the old Heave Ho and wiped Rocky from the NVMe 4.0 using GParted so I had a CLEAN drive.

This time I decided to try a DIRECT Reinstall though it would take hours to reconfigure. But as was the case when I tried to install Rocky 8.4 it would get to a certain point and throw the following ERROR message: "The following ERROR occurred while installing. This is a FATAL ERROR and installation will be aborted. DNF error : Error unpacking rpm package [Fill in the name of some rpm package]. I had checked the media 3 times and it always was reported as GOOD. To PROVE that the media was GOOD I wiped out the 2 TB HDD and installed it on there. It installed just fine!! No error messages no nothing, just a clean install. Having proved that would work I returned once again to GParted and wiped out the drive and started over, only this time I created it to fit on the 1 TB Corsair Force MP600 which reports out as being exactly 931.51 GiB. I created my Classic Partitioning scheme to be 931 GiB in size and left the 0.51 as a “slop factor” . I got KDE installed, and Xfce installed, and confirmed that the HDD with Rocky installed on it would indeed boot. I re-booted the machine several times. No problems!! Now I dug into my Bag of Tricks and planned to move the entire install over to the NVMe drive:

I issued the following command:

dd if=/dev/sda of=/dev/nvme0n1 status=progress

…only a few seconds later I received the following message " Out of space".

Back to GParted and wiped the NVMe drive clean again. This time I first BACKED UP Rocky Linux to a separate 1 TB drive and from there I tried to "RESTORE " Rocky Linux to the NVMe drive. A few seconds in I once again got the “Out of space” message.

This time before I wiped the NVMe drive clean I compared what was copied to the NVMe drive and compared it to the HDD drive. On the HDD I have the following:

Partition…File System… Mount Point … Label

/dev/sdb2… ext4…/media/sdb2…/home
[down arrow]
/dev/sdb4 [key]… extended…/media/sdb4

/dev/sdb10 [key]…linux swap…swap

On the NVMe drive I have /dev/sdb1 (/boot); /dev/sdb2 (/home); and /dev/sdb3 (/vm). BELOW THAT all that is listed is UNALLOCATED – No [Key]; No Extended Partitions; just “UNALLOCATED” space.

Just for FUN( and because I CAN, and just KNOW some would would ask) I decided to see what would happen if I did a total AUTOMATIC INSTALL and allowed the computer to do its own thing, hoping that it might point me in some direction. Nope, even with a totally AUTOMATIC INSTALL I still got the dreaded:

“The following ERROR occurred while installing. This is a FATAL ERROR and installation will be aborted. DNF error : Error unpacking rpm package [Fill in the name of some rpm package].”

My Bag of Tricks is now EMPTY. I feel a wee bit like Sisyphus: I solve one problem only to be slapped across the head by another. I can’t seem to win. I have ONE trick still left up my sleeve: Do a reinstall of CentOS 8.3, then HOPE when I Update and Roll over CentOS 8.3 => 8.5 it does not blow up (though I think I already tried this and it blew up).

There has got to be some way to move the entire sdb drive to the NVMe drive… or in the alternative do a direct install to the NVMe drive itself. Any help someone can provide would be greatly appreciated.


So I’m curious to see what we can find out about your install issue. Typically all nvme drives come with the GPT patition table and all ssd’s for that matter also. I see at least on the installs to the ssd that you have converted those to the msdos partition table. Did you do the same for the nvme?

[root@t4s ~]# parted -l | grep -i “partition table”
Partition Table: gpt

I retained the GPT table on my nvme and thus use the EFI firmware to boot.

Internal drives that you buy separately do not have any partition table.

External drives do have table and filesystem too so that you can just “plug and play” them.
OEM-built machines with pre-install obviously have table and filesystem.

Was the “DIRECT Reinstall” to Minimal Environment or did you choose more packages?

If /dev/sda is a 2TB block device, then dd would read 2TB from it.

What one could do is to create equivalent partitioning into the /dev/nvme0n1, and then copy separately the MBR and content of each partition.

PS. I would not use legacy on this day and age, unless the machine is so ancient that it does not support EFI.