Error Checking Storage Configuration

I am new to Linux and wanting to install Rocky Linux 9.2 on my iMac 2019:

Spec: Intel 8xCorei9, 1TB SSD drive, 128GB RAM, Radeon Pro Vega 48 8GB

I have wiped my drive clean, however I am not sure what method to use to erase the drive using MacOS disk utility APFS.

When I get to the installation screen, depending on how I have formatted the drive, Rocky Linux only detects around 1GB free each time.

When I select Automatic, Delete All and Reclaim all space, it still says I only have around 1GB free. I then receive the error message Error Checking Storage Configuration.

Is there something I am doing wrong here?


Any ideas?

I think I’ve solved the problem. I clicked Full Disk Summary and Boot Loader and removed the selected disk from the list.
Then went back through automatic partitioning and it seems to have worked.



OK, it looks as though by deleting the entry, it does not create a boot loader, so I’m back to same issue.

I did go into error message details:

Resource to create this format macefi is unavailable

Any suggestions please.


Im dealing with exactly the same problem… Did you solve it?

Hi Diego,

Sorry I have not had the time to look into this further, however I’m attempting to solve this time round.

I am attempting to install Rocky Linux 9.3 on my iMac replacing everything on it:

IMac 2019
Intel 8-Core i9
AMD Radeon Pro Vega 48 8GB

I downloaded the minimal setup from the webpage and I am currently on the Installation Summary Screen. I have completed the Localisation, User Settings and Software sections.

• In the Installation Destination, it says that I have 1.12MiB free.
• Storage Configuration Automatic
• Checked I would like to make additional space available
• I selected the disk 931.8 GB APPLE SSD SM1024L followed by DONE
• I then selected Reclaim Space
• I selected 931.8 GB APPLE SSD SM1024L followed by DELETE ALL
• The action shows the entire disk has a status of Delete
• I then click Reclaim Space and it takes me back to Main Screen
• The Error message on Installation Destination
• Error Checking Storage Configuration

Can anyone please point me in the right direction as I am at a loss on what to do next.


Just an update: I’m not worried about affecting any partitions etc… as I want Rocky to be the sole OS on my machine. I am happy to provide any tests, log files etc… to get this working.

Hey Clayton, I don’t have a mac so I’m probably not much help. I did ask around though and was told by someone that they had similar issues but this forum thread helped them:

Specifically the blog Linux sur les vieux iMac (2) – Installation du système de base – Le blog technique de Microlinux (Yeah, it’s French but the Firefox translation worked rather well for me and the eight article on partitioning might be useful to you).

If reading through that forum post and blog don’t help - can you post a few screenshots/pictures so I can see the issue you are having a bit more clearly?

Best of luck!

Hi Stack,

Many thanks for your reply and time.

Here are installation screenshots (apologies I had to take with my mobile phone)

Selected Installation Destination from the main list.

Selected the Apple SSD SM1024L disk and hit Done (below)

Select RECLAIM SPACE (below)

Select DELETE ALL (below)

Choose RECLAIM SPACE (below)

Error Check Storage Configuration (below)

Hope this helps.

Kind Regards,


Have you tried the links @stack posted since people have used those as a reference and got Rocky installed on a Mac?

I have now tried the links and followed the instructions for both GPT and MBR partitioning. However, when I return to the installation, I am now receiving the following error message:

Failed to find a suitable stage1 device Apple EFI Boot partition cannot be of type … Apple EFI Boot Partition must be mounted on one of /boot/EFI

Am I missing something here?


You need to have a partition called /boot/EFI of EFI type and probably 1G or so in size.