Dual monitor not working on latest Dell OptiPlex 7090

I have recently migrated all my office Dell OptiPlex desktops to Rocky Linux and I have a few variants 7060, 7080, and 7090. Dual monitor (DP1 and DP2) setup works on both 7060 and 7080 variants but not in 7090 variants. I have updated their BIOS and also updated Rocky Linux to the latest available version and all packages are up to date as well. There are no additional video or graphics cards are installed on the desktop and I also checked BIOS configuration to see if I have missed any check box but everything seems to be fine. Any help in this regard will be great.


In other words, you have two (DisplayPort?) monitors on Dell Optiplex 7090 (Tower/SFF?), on integrated graphics of Intel CPU, and they “do not work”.
7090 has 11th Gen Intel CPU, while 7060 and 7080 had 8th and 10th Gen, respectively.

Do you have anything in Wayland, X11, or other system logs?


Yes, I have two monitors connected to 7090 (SFF) via DisplayPorts and only the monitor connected to DP1 is working while the other displays “No DP signal from your device”.

No, I do not have anything in the logs.

What if you disconnect the display that does work? Will the other then get signal?

Nope, it does not, i already tried that too.

… and you have separately verified that both cable and monitor are functional, which leaves the connector on the machine (or hard/firm/software behind it) as only suspect?

Do those Dell’s have diagnostics tool in BIOS, etc?

Yes, I have switched the monitor 2 cables to DP1 port and it was working fine. I also ran the diagnostics and found nothing on it as well, these are new systems. So I started to suspect the driver, not sure what could be the problem.

If you go to UEFI/BIOS in 7060/7080, do you see the output via second DP?

If you can see UEFI via both ports on older models, but not on the 7090, then issue is not (just) the Linux driver.


Sorry, I was away from the office. No, I do not see the output via the second DP when in BIOS in 7060/7080.

For testing, I used a live ISO of Ubuntu 20.04 LTS and both the monitors showed output and everything works. So now I strongly suspect the video driver of Rocky Linux and wonder why it’s not working out of the box like Ubuntu.

@srikakulam Ubuntu 20.04 isn’t a great comparison since a lot of packages are newer. You would expect the latest Fedora to work also.

What you could try would be to download and install CentOS 8 in this machine and see if the problems occur, since this is more closer to Rocky as well as RHEL. These things can happen, I wanted to install Linux Mint 20 on my son’s laptop, but couldn’t get the AMD/ATI driver combo working yet it worked with Fedora 33/34 no problems purely because of newer kernel, drivers etc. I think you have a similar situation here.

Not sure if any other repositories would have updated drivers/modules etc that would help you get this working, maybe something is in epel, or elrepo that might help once these have been added to Rocky.

@iwalker Yes, you are absolutely right about that. I just happened to have Ubuntu on a USB stick and also I had my doubts that if there is a dual monitor problem on rocky then I expected the same to be with CentOS 8 as well. To verify this as you suggested I have installed CentOS 8 and the problem persists. I guess there is nothing much that I can do here, can I? Do you have any suggestions?

@srikakulam Even within software there are at least three layers:

  1. Kernel module. ELRepo has some kernel modules that RHEL does not ship. They might have better drivers that what does ship. (IIRC, a NIC did not work with default module, but ELRepo had a replacement.)

ELRepo also builds kernel-lt and kernel-ml from upstream sources. Those being kernel-5.x (now) gives chance that their modules fit new hardware (like Ubuntu does). Alas, then security patches to kernel depend on Linux kernel developers and ELRepo, rather than Red Hat.

  1. The part of driver that the windowing system (X11 or Wayland) contains. You have tested both X11 and Wayland to rule out that issue is not at that level?

On CentOS 7 and NVidia, virtual consoles show same content on both displays (i.e. mirrorred), but GUI does what GUI does. You have issue on both (virtual consoles and GUI) to rule out some more cases?

  1. The DE. When I got two displays to CentOS 7 I do remember tackling with the layout setup (both GNOME 3 and MATE), because X11 offers some layout management, but the DE has layout management too. Whether to use one, the other, or a mix … a mystery.

I know what you mean. I had the very same dual monitor situation when I bought 7080 and installed CentOS 7 and the dual monitor setup did not work but when I installed CentOS 8 the dual monitor setup worked fine. Once again now it’s the same situation. I am sure when Rocky is updated with the latest drivers for the latest Intel systems this will get fixed. I will try to find some time to manually check if there are any latest drivers available in 3rd party repo’s and I’ll try to install them and check if this gets fixed.