Does Rocky use Wayland? HDMI KVM Black Screen Prob

I want to install Rocky as my main development laptop.

But I have a side problem that I’m hoping maybe Rocky will fix.

For years I used a DVI KVM. Yesterday I just switched to a new HDMI KVM. Switching to macOS or Windows works fine. But when switching back to Linux, 50% of the time the external monitor goes and stays black. The monitor is on. The backlight is on. The output of xrandr -q shows both the laptop display and external monitor. The output of dmesg shows USB devices being discovered. But the screen remains black. No amount of switching back and fourth resolves the problem. The only way to fix the issue is to suspend the laptop and resume.

Fiddling with xrandr I see that many of the commands don’t work. I’m wondering if the source of my problems has to do with Wayland. I am currently using Fedora 35:

My question is, does Rocky use Wayland and if no, does anyone think that upgrading to Rocky would resolve my issue?

More generally, does anyone have ideas about why the external second display is just black even though xrandr -q lists both displays with the correct mode and rate?

It seems related to correctly recovering the HDMI state such as perhaps some kind of mixup between the display system (Wayland) and the EDID emulation implementation of the KVM.

At the graphical login (when already booted), you can change the session type to X11 instead of wayland (default in fedora and rocky). Enter your user id and when the password prompt appears look at the corner for this …

Yes, I was able to switch to X11 as you describe. Thanks for that info.

Unfortunately the problem remains. The external monitor goes blank.

I just noticed that if I do desktop > Display Settings > downgrade the resolution > Apply > Revert Settings, that fixes the issue. So it looks like just reloading X fixes it.

I am going to try to install the latest Rocky on a slightly different Latitude E7470 laptop and see where I’m at. Maybe the combination of changes will sidestep the issue …

For posterity,

Apparently there are many solutions to this screen blanking issue which is to say that just seems to be what happens when something with the Xorg / Xwayland display is not right.

There’s IgnoreEDID, snd_hda_codec_hdmi options, disabling SecureBoot in the BIOS, … I tried lowering the resolution, using a shorter cable, changing inputs on the secondary monitor … No change. When switching the KVM back to Linux, the secondary monitor backlight would come on, but the display was just blank.

However, Ctrl-Alt-F1 > Ctrl-Alt-F2 fixes the blanking. According to an authoritative sounding individual on the Internet, this suggests that the issue is isolated to the GPU as this procedure simply resets the GPU to it’s previous state.

So it’s not Wayland or Xorg or some kernel module or driver or whatever. It’s just the Intel HD Graphics 520 implementation in at least this series of machines (screen blanking occurs on both Latitude E7470 and E5470).

I put the Windows 10 drive back into the machine and it too has the exact same problem (it’s not you, it’s me).
In Windows I went to and installed all of the updates, BIOS, Intel graphics this, chipset that, … No change (but I do have to give dell credit for making the updating process very smooth).

At this point, the best I can do is:

Ctrl-Alt-F3 > Ctrl-Alt-F2

Note that using Ctrl-Alt-F3 is much faster because Ctrl-Alt-F1 launches the greeter (and if you try to switch back to quickly, it can leave the primary display blank and in a wonky state).

This procedure can be streamlined slightly by running:

# chvt 3 && sleep 1 && chvt 2

Any ideas about how I can minimize this pain?