Remote display server is not supported (e.g Wayland)

Good Evening team,

I have installed Anydesk Remote Desktop Application on my system Running on Rocky Linux 9. I wanted to remotely access my friend who is running on CentOS-Stream-8.

However, I get an error “Remote display server is not supported (e.g Wayland)

Doing a simple google search, I see an article that states that I can edit the **/etc/gdm/custom.conf
** configuration file and making the following changes.

GDM configuration storage


Uncomment the line below to force the login screen to use Xorg






Uncomment the line below to turn on debugging


am then to restart my server.

This did not solve my problem. PLease help me.

I know, but nearly all these articles are either out-of-date, or not applicable to Rocky. This config change was originally to foce xorg, but pure xorg is deprecated now.

Is there any work around ?

Please advise.

AnyDesk need to support Wayland basically:

Sooner or later if they don’t take action, and more distros are on Wayland than Xorg, then they will have problems because nobody will use the product. I use NoMachine like mentioned in the link, works great.

Try logging in with one of the other options (no Wayland). I use Anydesk and had the same problem logging in with Wayland. I have five (or six) log in options on my RL 9 installation.


@gerry666uk @iwalker @tht

I added the following line to the configuration file /etc/gdm/custom.conf on both the Rocky Linux 9 and CentOS-8-Stream.

AutomaticLoginEnable = true
AutomaticLogin = <my_user_name>

This seems to work for me as I was able to remotely connect to the colleague.

I am not sure if this is the proper way to do it, but it worked.

1 Like

I forgot to include that a system restart is needed for the configurations to take effect.

Thank you for this .

It also worked for me .