Chinese/Japanese language input not working?

Hi all,

I’ve been trying to type Chinese/Japanese characters in VS Code on KDE, but after following a few old guides to enable alternative keyboard layouts, the language switching icon and keyboard shortcuts do work, but the character suggestion window does not pop up. I’ve tried to install fcitx but for some odd reason dnf search fcitx doesn’t show any packages/results for installation. ibus doesn’t seem to be working either, as ibus-setup fails with a python error ModuleNotFoundError: No module named 'gi' (I’m on Python 3.9.18, which seems to be the default version)

Some help would be appreciated, thanks!

fcitx isn’t available in RHEL9 and clones. Last time I checked, which was awhile ago, ibus was working OK with Gnome. I haven’t tried with KDE though. I’ve not used VS code so I wonder if the issue is there, rather than with ibus itself.
On a more minimal install, using openbox it works for me with this in .xinitrc (or .bashrc)

export GTK_IM_MODULE=ibus
export QT_IM_MODULE=ibus
export LC_ALL=en_US.UTF-8

I have had more luck at times, starting ibus-daemon with ibus-daemon --xim

1 Like