CentOS Refusenik Needs Help

Since the errors occur during package installation (reading and writing processeeees), I suggest that you ‘test’ your storage device and your RAM to make sure either is NOT flaky.
If you’ve made a Gparted DVD or USB device, you should be able to access ‘memtest’ from it’s menu (non-OOOFEY (EUFI) only) and verify your RAM, and the storage device using something like CrystalDiskInfo to see if there’s any errors logged…

I have persuaded myself that Rocky Linux itself is fine on this Dell tower and has no problems with the graphics card. It’s taken me all day to do so, what with reverse-engineering various log facilities and lots of reboot-and-wait cycles.

Along the way, I discovered that this XPS 8940 has a 1TB HDD that I didn’t know about! I bought it because it has a 1TB SSD, and I guess I didn’t read the specs very carefully. In any case, I used an external tool (Acronis Disk Director) to shrink the Windows 10 SSD partition down to 100GB, leaving a total of ~830GB for Linux to play with (I left the various recovery partitions as-is). For this build, I let Anaconda do whatever it wanted automagically.

The result was somewhat unstable – it would crash and restart after about an hour of being idle – until I let it update itself. It’s now at build 4.18.0-305.10.2.el8_4.x86_64 (according to uname -a). It’s been running with no complaints and no crashes for about two hours now.

I do see some complaints in /var/log/messages that look a bit concerning:

Jul 28 18:47:16 localhost journal[2364]: gsd-xsettings: Fatal IO error 11 (Resource temporarily unavailable) on X server :1024.
Jul 28 18:47:16 localhost journal[2374]: gsd-keyboard: Fatal IO error 11 (Resource temporarily unavailable) on X server :1024.
Jul 28 18:47:16 localhost journal[2371]: gsd-color: Fatal IO error 11 (Resource temporarily unavailable) on X server :1024.
Jul 28 18:47:16 localhost cupsd[1340]: REQUEST localhost - - "POST / HTTP/1.1" 200 151 Cancel-Subscription client-error-not-found
Jul 28 18:47:16 localhost journal[2368]: gsd-clipboard: Fatal IO error 11 (Resource temporarily unavailable) on X server :1024.
Jul 28 18:47:16 localhost journal[2376]: gsd-media-keys: Fatal IO error 11 (Resource temporarily unavailable) on X server :1024.
Jul 28 18:47:16 localhost journal[2382]: gsd-power: Fatal IO error 11 (Resource temporarily unavailable) on X server :1024.

I don’t know enough about the X server to make much sense of them and hope I don’t have to go further.

I turned on persistent journaling (mkdir /var/log/journal) so the system will hopefully leave behind a little bit of information if it dies.

This all leads me to think that the nvidia driver issues I’ve encountered result from the kernel changes that are apparently needed to get Workstation Pro 16 running on this machine. That’s starting to look very much like an issue that only VMWare can address, so I’ll pursue it over on their boards.

Well things get stranger and stranger: I was just about to run MemTest and pulled out a thumb drive that had CentOS 8.3, and Memtest on it, and for a lark I decided to see if I could install CentOS 8.3. I did down and dirty and ran it as an automatic install of the Server w/ GUI. To my amazement it sailed right through – no error messages. When it said to reboot the machine I decided to do so expecting it to FAIL just like the one time before, not only did the reboot happen and I got through the lic agreement etc. I was able to install mc I then ran dnf update. It ran the update and rolled over the machine to CentOS 8.4.2105. The automatic partitioning scheme was not what I really wanted so tempted Fate and ERASED the entire disk and scrubbed it up, only this time I did the REAL INSTALL , complete with my Custom Partitioning scheme. I only installed the basic Server w/ GUI, No mods or other packages, just the bare bones Server w/GUI. Just like before CentOS 8.3 installed just fine. I installed mc (Midnight Commander) and then updated the entire machine. the updates rolled it over from CentOS 8.3 to 8.4, yet NEITHER CentOS 8.4 or Rocky Linux 8.4 Stable will install without throwing up that error message.

Now BEFORE contine down this “Rocky” road (pun intended) in THEORY I can convert a CentOS 8.4 install into a Rocky Linux 8.4 Stable install?!? If so that may well be the means by which I get Rocky Linux 8.4 installed. I am in the process of installing the Nvidia drivers and then installing kmod-nvidia. After that will be to install KDE 5.x.

It is possible that stumbled over a bug in RHEL 8.4, any distro that is a bug-for-bug copy of RHEL 8.4 including both Rocky Linux 8.4 and Alma Linux 8.4 will have that same bug in them. We can assume that the CPU is NOT the problem ( since it is a NEW AMD Ryzen 9 5900X with 12 cores and 24 threads that was on my chief suspects), but we can now eliminate that; the I thought it might be the the NVMe 4.0 SSD – but we can now eliminate that. The next suspect was the MEMORY – still possible and I’ll have to run MemTest on the 2 sticks, but that now looks less likely. That leaves the Graphics Card, the Graphics Card DRIVERS, or a bug. It is possible that in 8.3 there were DRIVERS for the NVIDIA GeForce GT 730, that were simply dumped in the CentOS when 8.4 came out – but hey how many people still rely on the VGA port?!? I do because my 4 position KVM switch requires it. RedHat has also gotten rid of supporting KDE. With both Rocky Linux and Alma Linux follow RHEL, then the question becomes will both follow Red Hat and provide no means to access KDE as a DE when Red Hat comes out with RHEL 9.x?? And there are a LOT of KDE users out there who detest using GNOME. This is one of the major reasons I am testing out openSUSE Leap15.3, an OS I know ZERO about as ever distro I have used has been based on some version of Red Hat (Mandrake Linux, Red Hat Linux [ not RHEL, but Red Hat 7.1 ] Fedora, RHEL, and CentOS). IF I can convert CentOS 8.4 over to Rocky Linux 8.4 that’s the path I’m going to follow, as CentOS is a Dead Man Walking (due to OFFICIALLY end 31 December 2021 at CentOS 8.5).

Assuming I can convert from CentOS 8.4 to Rocky Linux 8.4, before then I still need to do a fair amount of housework and package installations before I bail out of CentOS and convert.

Tom. Having [SOLVED ?? ] the install problem by INSTALLING CentOS 8.3 and rolling it over to 8.4 with the intent off converting the CentOS 8.4 to Rocky Linux 8.4. In the meantime I have set about re-installing a lot of packages, updating packages etc, Part of the process includes reinstalling the Nvidia drivers and the kmod nvidia drivers. When I fell over the thing about “nouveau”.

Here is the reference:

Step 4 requires you to:

Edit /etc/default/grub. Append the following to “GRUB_CMDLINE_LINUX”
rd.driver.blacklist=nouveau nouveau.modeset=0

Step 7 requires you to:

Create (or edit) /etc/modprobe.d/blacklist.conf and append the following:
blacklist nouveau

Step 8 requires you to:

Backup the old initramfs and build a new one
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)

These are the instruction I sort of remember having to do several years ago. I thought it had to do with BLACKLISTING NOUVEAU.

I am sure I will fall over other stuff. As I recall there was something that had to do with microcode as well.

I’ll keep you posted as I stumble across “other stuff” In the meantime I hope this helps.


I appreciate this. I’ve started another thread about my own saga.

You’ll enjoy the irony that I attempted to use Fedora Media Writer to create a bootable USB stick with the official CentOS 8 dvd iso, just to get a comparison point. That tool (which I used to create my Rocky Linux sticks) is unable to put the CentOS 8 iso onto a stick using WIndows 10 Pro.

I’ve tried three different sticks from different manufacturers on two different systems with exactly the same result – it complains of an unspecified error and says that the media “is probably damaged”.



OK I can tell you without a doubt that CentOS 8.3 DOES install; CentOS 8.4 and Rocky Linux DO NOT install even with fresh media and burned on 2 different sticks each. If there was a way for me to screw up an install I managed to do it (I think I installed CentOS 8.3 at least 5 times) but the take away is that it DID install EVERY TIME without a hitch. My GUESS is that there is indeed a bug in RHEL 8.4 and given that CentOS 8.4, Rocky Linux 8.4 stable and (by extension ) Alma Linux are “bug-for-bug” copies of RHEL, any bug in RHEL will show up in the “FREE” versions of RHEL.

I have since managed to get both kmod-nvidia, and the nvidia drivers to install (that was two of my installs I managed to screw up). I then managed to screw up the install sequence of of the repos for Nvidia. and finally I managed to screw up the install of KDE Plasma twice.

There are some programs – IF available – I still need to see if I can install on CentOS 8.4 before I see if I can convert it to Rocky Linux.

After a LOT of hair pulling and head bashing I managed to get KDE 5.18.4 to look like KDE 4.14.x – 10 different quasi Virtual Desktops each with its own Wallpaper, and each with its own set of widgets. I say “quasi Virtual Desktop” because in reality it is NOT a Virtual Desktop at all, but rather an “Activity”, a concept that the Devils at KDE 5 are force feeding Users: “You will like what we give you; you will EAT what we present you with”. Instead of cloning the Virtual Desktop way and perfected in KDE 4.14, KDE 5 decided to try and re-invent the wheel. At some point I will post instructions on how to achieve that KDE 4.14 look and method. There is only 1 YouTube video on how to achieve it, and it truth I’d only give it a C+ rating. A lot was just plain stick-to-it-ness and trying experiment after experiment 99.9% FAILED before I stumbled across the magic formula. It ain’t pretty, but it is repeatable. IF someone needs to know HOW I manged to pull off this hat trick, PM me and I get back to you ASAP but it may take a few days. A lot depends on if it is RAINING and I am suffering from a MIGRAINE, and am confined to my bed; or if I am trying to finish other projects, but I WILL answer you ASAP. The life of an Ex-research Scientist.

While I am still trying to get ocelot – my NEW workstation on line – my current workstation, leopard, is about to get plastered with a LOT of CoViD 19 data. If you have not already gotten vaccinated, consider doing so ASAP!! CoViD 19 / “Delta” I suspect will, within 2 months, give rise to CoViD 19 /“Epsilon” . May we live in “Interesting Times”.


From upthread:

I enthusiastically concur with this recommendation.

After two weeks of thrashing with this hardware, today I returned it to Tech Micro Center (where I bought it) for a full refund.

I bought the workstation I’m using now more than ten years ago from Digital Storm. Now that I know what to ask for, I’ll buy my new system from them.

I suspect that with proper BIOS and graphics support, I’ll do just fine with Rocky Linux – I’ll ask Digital Storm to install that, along with VMWare Workstation Player 16. I’ll go with whatever graphics card DS recommends.

From now on, my recommendations to colleagues, friends, and family about Dell will be the same as yours.


fedora media writer should work so did you verify your iso after you download it
if yes and you still has the same issue try Rufus - Create bootable USB drives the easy way

1 Like

Interesting, I hadn’t thought of that. I’ll try that.

You absolutely CALLED that one, my friend.

I ran the sha256sum on the download I was using, and it did not match. I downloaded a fresh copy of the ISO, ran sha256sum, confirmed that this time it did match, and – voila – fedora media writer was happy.

So the issue was a corrupted download. Fascinating.

1 Like