Build of wireguard module fails on Rocky 8.8 (kernel 4.18.0-477.*)

We’ve been using wireguard to remotely access my company’s infrastructure. It’s been working like a charm with Rocky 8.7 (kernel 4.18-425-*) but the module doesn’t seem to be built since we’ve upgraded to Rocky 8.8 (kernel 4.18.0-477.*)

The bug seems reproductible on newer deployement (installed with Rocky 8.8). Despite installing wireguard + wireguard-tools, the wireguard module is absent after reboot.

# modinfo wireguard
modinfo: ERROR: Module wireguard not found.

Trying to manually build the module with akmods also fails :

# akmods --force
Checking kmods exist for 4.18.0-477.13.1.el8_8.x86_64      [  OK  ]
Building and installing wireguard-kmod                     [ÉCHOUÉ]
Building rpms failed; see /var/cache/akmods/wireguard/1.0.20220627-4.el8-for-4.18.0-477.13.1.el8_8.x86_64.failed.log for details

Hint: Some kmods were ignored or failed to build or install.
You can try to rebuild and install them by by calling
'/usr/sbin/akmods --force' as root.

I’ve pasted the log file here if that’s of any help :

So kernel-headers (4.18.0-477.13.1) are installed in case anyone is wondering.

Any idea of to solve this?
Any hints welcome.


You may want to use the kmod-wireguard package offered by ELRepo. It is kABI-tracking, meaning it survives kernel updates withing a minor release (8.8 for example).

Thanks a lot, that was it. ELRepo was the missing piece of our setup.
It even solved a minor issue with a nvidia driver, everything runs smoothly now.

Great to hear it worked out. :slight_smile: