Booting Rocky 9 on old Mac Pro

Install Rocky 9 on Mac Pro 2009-2010

Not enough information for people to help you. I suggest you put more effort in if you want people to help, and for you to clearly and concisely explain what you are doing, what you have tried, and what isn’t or is working. If you cannot put in the effort to ask the question properly, why should people put in the effort to help?

Also search the forum, since there are already posts here about installing Rocky on a Mac. I suggest you search for those posts first before continuing with this one.

Hi @iwalker, I’m sorry about my way to initiate my participation here lacks all the relevant information. Apologies. It was a couple of hours past midnight and I found this forum. I have been battling for more than a week already trying to run a Linux system as only operating system on my old Mac Pro in order to run DaVinci Resolve for Linux on it. A few things haven’t worked well yet, so I’ve been learning quite a lot. I’m totally new to Linux.
I’ll gather detailed technical information about hardware, software and steps I’ve followed and I’ll post proper information here, so that if I succeed runing Resolve and Fusion (compositing video application included in the free DaVinci Resolve package) on an early 2009 Mac Pro, also other users can find the information and continue to use these old Unix-based machines that are really great.
My current experience is that after managing to complete a Rocky 9 installation of the machine’s formatted boot drive, after pressing “reboot”, the computer does not boot.
I found a post talking about a “–nomacboot" flag in Rocky installer. The next thing I’ll do is to learn more about that and try a few things to see if I can get my old Mac Pro to boot Rocky 9.
I’ll post my findings here.
Here’s that post : Error installing Rocky 8.4 on macbook pro - #5 by deleted-account

You may want to make sure that the CPU in that particular machine is at least x86_64-v2 since this is what Rocky 9 requires as a minimum (as chosen by RHEL that Rocky is based on). So it could also be worthwhile testing Rocky 8 on it as well.

Thank you @iwalker . Rocky 8 presented the same behaviour. I struggled to install because of an issue getting it to accept the system destination hard drive, and when it actually completed the installation process, it failed to boot the system.
I put the question to a release engineer a moment ago. I hope to learn enough to overcome this issue and see if DaVinci Resolve will run well enough on Rocky 8.6 or higher, on my old machine.
Here’s the post I just wrote: Rocky Linux 9.3 Available Now - #8 by Lortega70
Thanks and best regards,
Leo

The --nomacboot flag is required for us to properly make ISO images for x86_64. Otherwise, lorax (the utility we use to make the images) will not work as it cannot find a package called mactel. We were asked before about removing this flag, but without that package, we can’t remove it.

My suggestion is to look at this bugzilla comment to get an idea of what to do.

1 Like

Thank you very much, @nazunalika , I’ll follow that thread.

The easiest way I found to install rocky 9 on a 2014 macbook pro was to use VirtualBox to install straight to an external USB drive.

1- Launch VirtualBox from a MacOS terminal with ‘sudo virtualbox’. If not you wont be able to connect your physical USB drive to your virtual machine.

2- Create a virtual machine and boot from the Rocky Workstation live ISO.

3- Connect your USB drive to your virtual machine

4- Format your disk using the Disks app. Make sure to use a GPT partition table.

3- Run the installer using your USB drive as the target disk.

4- Shut down the VM, reboot your Mac and press option to select the boot disk.

Profit? I think you should be able to boot from your new Rocky install now.

Installing in a VM enabled me to bypass the installer restriction that refused to install a bootloader because it was running on a Mac.