Boot issues 9.3 Performance Metrics fail

This happened last year… It effects all of the Linux versions in the start up process menu.

Might have occurred during the 9.3 update, it was certainly after that as 9.3 is an option in that menu.

What don’t I know?


This looks like the issue.

Does anyone have access to that forum?

That knowledgebase is accessible with the free Red Hat developer account.

However, the TLDR of the article is:

Reinstall Performance Co-Pilot:
dnf reinstall pcp

Restart services:

systemctl start pmcd
systemctl start pmlogger

It appears the issue the article is for is that /var/lib/pcp/pmns/root somehow ends up empty?

OK how do I quit the boot process and get a prompt?

Never had to trouble shoot Linux and I have too many unknown unknowns.

If I have to reload the OS for some reason, does it obliterate settings etc?

Hence why I’ve put this off.


If you’re not able to get to the login prompt at all, guess you’ll need to use single-user mode or (see

What I’ve managed/learned

esc to read the background boot screen
Ctrl+Alt+F1 to continue to read the background process

Press e at the GRUB startup screen.
After the string quiet, add the parameter rd.break, and then press Ctrl+X to exit the parameters editor and continue booting.

Clearly, I’ve got to work my knowledge up from the basics.

I did manage to get a prompt and I’ve attempted to remove pmcd.

It’s a test of endurance… Do you have a way to increase text size from a prompt got via ctrl+alt+F"4"? The text on the UHD display is so tiny.

[1.266329] Integrity problem loading x.509 certificate -74 & -126

Can’t be that had to get a solution now I have a prompt.

Don’t know what to do. I’m sure it is just a matter of editing what is trying to start this and stop it blocking the boot process.

Log in as root (the superuser).

Change to the PMDA’s directory as shown in the following example:

cd ${PCP_PMDAS_DIR}/elasticsearch

Enter the following command:


The following output illustrates the result:

Culling the Performance Metrics Name Space ...

elasticsearch … done
Updating the PMCD control file, and notifying PMCD …
Removing files …
Check elasticsearch metrics have gone away … OK

I’m guessing it is something like that. Just there is no elasticsearch and using find I can’t locate the files. I think the files might be deleted and the issue is they are being called and I’ve not found a means to manage that.

This is what I’m seeing…

boot process

file directory search

not sure that makes sense or matters

trying to start but failing

I just don’t know the way to stop PMCD from trying to start and if there are files for that on the system I don’t know where they are. I’d have used dnf remove or something like that to rid myself of this thing.

I have no idea why this has such a priority that it blocked the log on screen.


Humm… I’ve disabled Samba and PMCD so those errors are gone.

Now I see

Starting Terminate Plymouth Boot Screen (is that normal)

And the system stops at

Started System Lobbing Service

Solved… well resolved really.

All too easy if you go in the right direction…

Grabbed a network cable and connected the linux box to the pc that had internet access.
Booted as far as it could then got a terminal F3.
ran dnf upgrade --allowerasing

A month of reading bull on the internet and a problem so easy to solve by just letting the system do what it is good at.

Definitely feel a bit more confident that I’m not going to be stuck with an issue that takes a month to resolve again.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.