Boot iso can't find repo url

I tried installing from a boot only iso. With Alma, for network, once I set the connection, it automatically chooses closest mirror and begins downloading. However, with Rocky, when I did this it was unable to find repo source. The network was working. I tried this both on a wireless laptop and a VirtualBox install.
My workaround was to use the minimal, rather than the boot iso and install from media. (Minimal install iso was also unable to find a repo.
As I’ve seen no reports of this, I suspect I’m missing something obvious, but haven’t figured it out. In all cases, the network was functioning, and when I went to a console, I could ping by both IP and name.

You didn’t mention which version, but if Rocky 9 it could be overloaded mirrors. When it was released a couple of days ago, I installed from the DVD iso, as I heard of issues until the mirrors have finished syncing.

There are a load of mirrors attempting to sync all the repositories, so if it’s overloaded with connections and your machine attempts to connect it can fail until some connections become available. Or you may have connected to a mirror that hasn’t completed syncing yet. All I can think of right now.

Pft you’re right, I didn’t mention that it was Rocky 9. Your answer makes a lot of sense and I thank you. (I also didn’t mention that I verified the checksum). As I installed it with the minimal iso, I’ll just check it in a few days with a VM.
Thank you.

1 Like

I was looking to create a similar thread. Some mirrors have the “9” folder but media.repo file is missing. Netinstall tries to get this file.

Typing this URL in “Installation Source” can solve this. Remind to change "closest mirror" to http:// or https://.

Or a mirror with media.repo file, for example:

In a few days the mirrors will have synchronized.

I had tried that too. I see my first post was rather uninformative, missing too much important information. I tried with https:://dl.rocky/etc and it still couldn’t find a repo.

And…just tried it again, typing in the url dl.rockylinux, and this time it workd. Maybe I mistyped last night. Thanks.