Xrdp not working after update

After update from 0.9.21-1.el8 to 0.9.22-3.el8 /usr/lib64/xrdp/libvnc.so is missing.
I have Rocky Linux 8.7 4.18.0-425.19.2.el8_7.x86_64

1 Like

I did update today on both Rocky8 and CentOS8 boxes and can no longer RDP from Windows 10.

I get the normal log-in prompts and get the message “login successful for user…”

Followed with the error:
“error loading libvnc.so specified in xrdp.ini, please add a valid entry like lib=libxrdp-vnc.so or similar”

“locate libvnc.so” yields “/usr/lib64/xrdp/libvnc.so” but a look into /usr/lib64/xrdp/ contains no such item.

I removed and reinstalled xrdp and tigervnc-server but nothing changed… any idea what might have happened? I have been using this RDP reliably until after today’s update.

Huh. I got the exact same problem with Alma 9.2, and spent hours today trying to fix it. No luck so far. I also tried using different lib=somefile.so substitutions, which also didn’t work.

Rats, I have the same problem now using Remmina from a Fedora box to connect to xrdp. Should have read the forum before upgrading. Hope there’s a fix out soon.

Same problem here after upgrading to RL9.2.

Here is a workaround.

$ wget https://dl.fedoraproject.org/pub/archive/epel/9.1.2023-05-09/Everything/x86_64/Packages/x/xrdp-selinux-0.9.21-1.el9.x86_64.rpm
$ rpm2cpio xrdp-0.9.21-1.el9.x86_64.rpm | cpio -id
$ sudo cp usr/lib64/xrdp/libvnc.so /usr/lib64/xrdp/

xrdp is an EPEL package, so it’s not strictly an Enterprise Linux issue. See the following bug report: 2207769 – xrdp xrdp-0.9.22-3 missing libvnc.so

@SH2 on the right track… I happened to have another box that had yet to get updated so I copied both:
and dropped them into the /usr/lib64/xrdp/ of the updated system and xrdp now functioning as it should.

I did have to killall -u on one of the systems to get logged-in.

This trick worked on both the Rocky 8 and CentOS8 systems.

I tried that on my broken 9.2 box via SSH and got a “no such file or directory” for my trouble. I tried copying the libvnc.so file from a box still running 9.1 to the 9.2 box and was successful. I thought it didn’t work either since the session closed immediately then I noticed that I was still logged on to the box directly. I logged off the box and tried RDP again and connected successfully. Will there be an update to the 9.2 install to make this file copy rigmarole unnecessary?

I’m in the middle of pulling six RL 9.1 systems out of my cabinet and connecting them to a display/kb/mouse to do the upgrade then copy libvnc.so off a file server to them. Four down, two to go. Happily it’s an easy fix.

1 Like

Update: Just did another dnf update and it found a new xrdp package. Installed it and xrdp works again!

Good job devs!

I’m updated to 1:0.9.22-3.el8 and it’s still broken. What version is the fix on? is working for me.

I have the same problem, but more, I am not able to login localy. SHIFT nor ESC doesnt work, better a screen reveal with some boot option, but any of them finish with the black screen trying to open x-server, and its all; no usefull screen. How can I break it and make Rocky (8.7) to boot into a console?