Wayland not available anymore after nvidia installation

Hi all :slight_smile:

First of all, I’m new to the forum but also to linux in general. please forgive my stupid questions :wink:

Some days ago I installed Rocky Linux on a notebook, but after installing the nvidia driver, there is now no more Wayland.

  • Rocky Linux: up to date, installed from the full DVD iso in “workstation” config
  • Nvidia driver: installed from rpmfusion, following the tutorial on their page. Version 525.78.01

Now, the driver installation went flawlessly, no problems. But after a restart, I recognized that the 3-finger-swipes on the touchpad wouldn’t work anymore, so I started investigating and found out that my linux is now running on X11, according to the system info. It was Wayland before.

Possible cause, but I’m not sure if it’s related:
the laptop has intel onboard graphics + a nvidia card. There seems to be the feature “nvidia Optimus” which allows the usage of both, also the system info now lists both graphic adapters (before the nvidia driver install only the intel was listed there) :


rpmfusion states that:

The cogwheel on the login screen only gives me options for “gnome classic” and some others, but none of those enable Wayland again.

Is that normal behavior?
Does anybody have a optimus-config running with Wayland?
What can I do?

(I still need to find out if x11 instead of wayland has any real disadvantages… however i guess it was set to wayland initially for a good reason)

thank you,

Rocky9 is not Fedora and the snapshot that is taken to produce EL9 is based on Fedora34. So, I think its hardwired to X11 for now (without testing it). This can change in the future if and only if some requirements for that NVIDIA support are rebased.

Wayland is the successor of X11 displayserver. Its an upgrade in different areas but it does not mean that X11 is “bad”. It depends on your requirements for instance some screensharing applications only work under X11 …

Thank you for your answer. although i was hoping for some way to fix this. obviously :wink: but it seems there is not much I can do.

Hi, @kris I came across this post when encountering the exact same issue. I have just managed to find a ‘fix’ and get Wayland running again. I use the term ‘fix’ as I don’t believe it is supported.

  1. Install nvidia-driver latest-dkms:
    1.1 sudo dnf module list --available
    1.2 Ensure Stream latest-dkms is [d]efault and [e]nabled
    1.3 sudo dnf module install nvidia-driver

  2. Follow the commands for amending grub2 here: https://forum.getcryst.al/d/14-how-to-make-gnome-wayland-work-on-an-nvidia-gpu
    2.1 Open /etc/default/grub with sudo/as root
    2.2 Add this line: GRUB_CMDLINE_LINUX_DEFAULT=“loglevel=3 quiet nvidia_drm.modeset=1”
    2.3 Save
    2.4 Run: sudo grub2-mkconfig -o /boot/grub2/grub.cfg
    2.5 Run: sudo ln -s /dev/null /etc/udev/rules.d/61-gdm.rules
    2.6 Reboot

  3. Lastly, if the above doesn’t bring Wayland back, I also ran this command as standard user and sudo:

gsettings set org.gnome.mutter experimental-features ["kms-modifiers"]

I don’t know if this actually made a difference, as I did it before finding the grub2 amendment steps and it didn’t bring Wayland option back by itself. So don’t run if you don’t need to, given its experimental status.

After doing these steps, Wayland is now available and working, along with Nvidia drivers:

$ nvidia-smi
Wed Mar 22 19:28:44 2023
| NVIDIA-SMI 530.30.02 Driver Version: 530.30.02 CUDA Version: 12.1 |

System Build Spec:

OS: Rocky Linux 9.1 x86_64
Kernel: 5.14.0-162.18.1.el9_1.x86_64
DE: Gnome
WM: Mutter (Wayland)
GPU 1: Intel UHD Graphics 630
GPU 2: NVIDIA Quadro T1000 Mobile

Hope this helps if you haven’t already found a fix. :slight_smile:

Thank you. Actually I also have found a “fix”, a pretty easy one actually! :stuck_out_tongue:
Just like you, I have no idea if it actually is a “fix” :wink: For me it works, but I have no idea if it has any negative consequences.
So, use at own risk…

I’ve found it here, but I followed post #5, and not the whole initial “comment out” procedure:

Basically, I edited the file:
opened it with root, went to this part, in my file it’s line 76,
# If this is a hybrid graphics laptop with vendor nvidia driver, disable wayland

and in one of those lines below just replaced


saved, and that was all what was needed.

After a reboot it was still set to X11 on the login screen, I believe, but the option for wayland was back, and after choosing it once it also “survived” the following reboots and stayed selected.

Is that the “right” way? no idea…
Actually I’ve been meaning to check out what this file looks like in newer Fedoras, where this appearantly is no longer an issue (?), but so far I haven’t…