VB7, DNS and OpenVPN [Rocky9]

Hello everyone,

I recently tried to replace some old CentOS 7 VM, thought I have an issue only on Windows Hosts.

I Import a Rocky 9.3 VM i created in Virtualbox 7.0.12 (Exported from Linux host and imported to Windows 11 host) same version and everything. I have an issue which CentOS 7 didn’t have with the exact same settings. When the host is connected to OpenVPN (CloudConnexa) the vm times out or resolves and pings very slowly. Tried a bunch of things (Disabling IPv6, OpenVPN client settings, different DNS Server (Public ones)) but nothing worked out. DNS server is set to 1.1.1.1 or 8.8.8.8 for example.

When I disable the OpenVPN the DNS resolution works fine and fast. The VM has 2 adapters, one in NAT mode (Internet Access) and one Host-only for accessing through host. Maybe it is a VirtualBox issue, but any recommendation?

On the Linux host where I created the VM it works fine with openvpn3 running and connected. CentOS 7 work fine on the Windows Host. I only have the issue with the Rocky vm on Windows Host.