Unable to use quickemu

I’m attempting to use quickemu under Rocky Linux 9.1, but when I execute it I get the error:

ERROR! QEMU not found. Please make install qemu-system-x86_64 and qemu-img

I have installed qemu-kvm and qemu-img, but it is not enough.
Any suggestion of what I could try to install? qemu-system-x86_64 is not available even with epel enabled.

Ok I found out a simlink from /usr/libexec/qemu-kvm to /usr/local/bin/qemu-system-x86_64 was enough.
Next I also needed spicy so I installed the nix package nixpkgs.spice-gtk.
Now it is attempting to start but I’m stuck with the following error:

socat E connect(5, AF=2, 16): Connection refused

will try to sort it out.

Any reason, why you chose quickemu over libvirt & virt-manager?
Those should be readily available on Rocky.

You can install everything you need by running

dnf groupinstall "Virtualization Host"

And: it works out of the box.

Just curious

Cause I managed to get a fast windows 11 VM under Ubuntu with quickemu.
But qemu-kvm doesn’t support any display that I can use in Rocky, only: none and egl-headless.
The socat error above was due to the fact the vm was terminated with the error
qemu-kvm: -display sdl,gl=on: SDL display supported is not available in this binary.
If I try a qemu from nix it includes support for sdl but it fails
qemu-kvm cannot use dsl qemu-kvm: ../src/dispatch_common.c:885: epoxy_get_proc_address: Assertion 0 && "Couldn't find current GLX or EGL context.\n"' failed.
I have mesa GL libraries, but I don’t know how to start a GLX or EGL context.

So I went back virt-manager: the vm starts but the windows 11 installer refuses to install telling me it does not satisfy the minimal requierments: I configured 4 cores, 8GB of ram, a 100GB volume, and virtualized TPM. Not sure, but I don’t find any option to enable UEFI as suggested here: virt-amanger under “Hypervisor details” reports only “Chipset: BIOS” with no option to use UEFI.

And I have edk2-ovmf installed.

Not sure, but I don’t find any option to enable UEFI as suggested here: virt-amanger under “Hypervisor details” reports only “Chipset: BIOS” with no option to use UEFI.

Yes, that one is a bit obscure: It is only selectable once BEFORE creating the VM.
To show the configuration dialog, in the “Create new virtual machine” wizard, you must check
the checkbox labeled “Customize configuration before install” in the “Step 5 of 5” dialog.
After that, the normal VM configuration dialog is shown. Now both the chipset and firmware
can be selected. Keep the chipset as “Q35” and in the firmware combobox you can then change
it from BIOS to various UEFI variants with or without secure boot.

In the doc you linked, the corresponding dialog (with the important checkbox) is shown just
before the heading " 3. Configure the virtual hardware for windows 11 in KVM."

And another thing: In that doc, they recommend selecting the chipset as i440FX
That might be necessary for win11 (My advice to use Q35 stems from OpenStack docs
and I myself have not tried win11 yet - i normally use several windows server VMs on OpenStack)

1 Like

Yes, thanks that was the point.
Recreating the VM I managed to select the UEFI BIOS and to install Windows.
The qemu-kvm without spice is rather limited. Reoslution is 1280x800 and speed is suboptimal.
Tomorrow I’ll try to use the qemu from nix to see if I can get something better.

The qemu-kvm without spice is rather limited.

Hmm. virt-manager does spice by default when creating a new VM?!

The QXL/Spice is deprecated in el8 and is not at all in el9. See 2030592 – Keep QXL/SPICE support for RHEL 9 for some reasons.

Oh crap. Good to know. I’m currently on Fedora (36) and there, it still exists. Why the heck did they do that?