Unable to boot/install Rocky Linux 8.5 on ESXi 7u3

I have an ESXi 7u2 Hypervisor running with some RockyLinux Guests.
Everything worked fine exept a know bug considering SD-Cards.
Today I tried to address this bug buy upgrading to ESXi 7u3.
The upgrade works without a problem.
However after the upgrade All RockyLinux Guests are unable to boot.
I only get an “bootloader not found” message.
I also checked the options of the VMs and noticed that Secure Boot was enabled. So I disabled it.
My problem is that it did not have the desired effect. I still get the “bootloader not found” message.
I am also unable to install a new rocky linux guest when mounting the iso.
If I try the screen went black or show som funny color fragments and the vm gets stoped automatically.

Any ideas what is happening here?
On the same host there is a photon guest, that works flawlessly. Most likely because the boot option is BIOS not EFI.

If nothing happens my last resort is to drive into the Server Housing and downgrade the esxi host. And hope that the vms will start working again…

Little update: My tests show that when choosing BIOS as boot option at least the installer is starting.

Ok, some new facts.
Reverting VMWare to the previous version (Hitting Shift+R) during bootup of VMWare works.
The Rocky Linux Guests are running again.
I then installed the newest patch for ESXi 7U2 which works too.

  1. The problem might not be related to Secure Boot Since Secure Boot option works for ESXi 7U2
  2. The problem appears if I update from 7U2 to 7U3 with esxcli commands. Since this was a production machine and time was of the essence I did not have the time to test if an new install of 7U3 would work.
  3. Since it was critical to bring the server back up running I did not test if the problem was RockyLinux related or a general problem with EFI after updating using the HP patch packages.
  4. To reproduce the error
    4a) Install VMWare from newest Custom HP iso for ESXi 7U2.
    4b) Update to VMWare ESXi to 7U3 using HP patch depots. Using VMWare patch depots does not seem to update anything at all.
  5. To reproduce the working patch
    5a) Install VMWare from newest Custom HP iso for ESXi 7U2.
    5b) Update to newest 7U2 patch using this commands
esxcli network firewall ruleset set -e true -r httpClient
esxcli software sources profile list -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml

pick the newest 7.0U2 profile or whatever you like and run

esxcli software profile update -p <profilename> -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml --dry-run

Check what the update is doing. Maybe you need to set the host in maintenance mode or if you use old hardware that is not officially supported you have to use the --no-hardware-warning. After verifying run the same command without --dry-run

esxcli software profile update -p <profilename> -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml
esxcli network firewall ruleset set -e false -r httpClient

My Host is now running 7.0U2e without problems. I did not try to update any funder because this was a production server but I hope this info helps at least someone.

Are there any logs remaining from when the host was on 7u3, saying (for example) “can’t start guests because…”

I did look into it but I found nothing inside the logs, sorry.
In fact the guest was starting just fine when booting an installed linux system it just could not find the bootloader and when booting the installation iso of 8.5 after the boot options the screen was black and after some time shows color dots. It stayed in that state forever till I shut down the vm.
So I think vmware did think that the vm was started…

Do you have any way to installing 7u3 onto spare hardware, and then see if Rocky 8.5 can install at all. e.g. is this issue only related to VMWare upgrades, or is it that 7u3 doesn’t work at all…

I do have spare hardware now and can test. But my time is limited so it might take some time till I can come up with a detailed report

Ok, i was able to test it. Sorry for the long delay
It seems that Rocky Linux + ESXi 7U3 + at least my HW is a no go in every way i tried.
The only thing working is ESXi 7U2 + Latest Patches without upgrading to U3. That’s fine with me.

What my tests with U3 shows (all done with images loaded from the hompages today)

  1. I am unable to determine if the problem is RockyLinux related only or a combination with my hardware.
  2. RockyLinux is not working at all on ESXi 7U3. Installation from an ISO image gets a black screen and existing VMs stopp working.
  3. Ubuntu Server shows an “No compatible bootloader found” message when trying to boot from an ISO
  4. CentOS Stream 8 seems to boot and install just fine. I did not make an effort to check every OS function but at least it is booting.

I tried

  1. Install ESXi 7U2 HPE Custom Image + HPE Upgrade pack to 7u3
  2. Install ESXi 7U2 HPE Custom Image + Upgrade with ESXi 7U3 HPE Custom Image
  3. Install ESXi 7U3 HPE Custom Image directly
  4. Install ESXi 7U2 HPE Custom Image + Update to newsest U2 Patch status with the method posted here Unable to boot/install Rocky Linux 8.5 on ESXi 7u3 - #2 by Swtrse

On the VMware site it says they pullled 7u3, 7u3a and 7u3b, and now they’re on 7u3c, so maybe there’s some major issue with what ever they are trying to do.

I know that they had problems with 7U3 and it was only recently that 7U3 versions are available again since the had to sort out the massive problems they had with the initial 7U3 version.

However currently available 7U3 versions should be fine to use but did not work for RockyLinux.
The HPE image and the direct patch I tried are all based on 7u3c.
I will try to move from HP profile image to VMware Profile like I did with 7U2 for the patch. And see If that works out. But you have to give me till the weekend.

Good news, I updated the 7u3 VMware on my system (running an HP custom image) to the newest VMware patch, as described in my previous post with 7u2.
As soon as the HP specific components got replaced by the native VMware ones, Rocky Linux started to work on 7u3 just fine.
So this is a bug in the HP custom images of VMware

Interesting, thanks for letting us know.